aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2025-02-09 13:41:57 +0000
committerdakkar <dakkar@thenautilus.net>2025-02-09 13:41:57 +0000
commit5344b632125ea5ceefd81046d3ecd48efd94f997 (patch)
treecf92c295379edf9b42ce8ce32f7c11f7c7da43e4 /Makefile.PL
parentv1.1.3 (diff)
parentDzil-build release 1.0.5 (from ad3b210 on master) (diff)
downloadSietima-5344b632125ea5ceefd81046d3ecd48efd94f997.tar.gz
Sietima-5344b632125ea5ceefd81046d3ecd48efd94f997.tar.bz2
Sietima-5344b632125ea5ceefd81046d3ecd48efd94f997.zip
Dzil-build release 1.1.3 (from 0a1efc2 on master)v1.1.3
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL105
1 files changed, 105 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..16fb39e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,105 @@
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.032.
+use strict;
+use warnings;
+
+use 5.036000;
+
+use ExtUtils::MakeMaker 7.30;
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "minimal mailing list manager",
+ "AUTHOR" => "Gianni Ceccarelli <dakkar\@thenautilus.net>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => "7.70"
+ },
+ "DISTNAME" => "Sietima",
+ "LICENSE" => "perl",
+ "MIN_PERL_VERSION" => "5.036000",
+ "NAME" => "Sietima",
+ "PREREQ_PM" => {
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.954",
+ "Email::Sender::Simple" => "2.601",
+ "Email::Stuffer" => "0.020",
+ "List::AllUtils" => "0.19",
+ "Mail::DMARC::PurePerl" => "1.20250203",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
+ "MooX::Traits" => "0.005",
+ "Type::Library" => "2.006000",
+ "Type::Params" => "2.006000",
+ "Type::Utils" => "2.006000",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.006000",
+ "Types::URI" => "0.007",
+ "feature" => "1.89",
+ "namespace::clean" => "0.27",
+ "strict" => "1.13",
+ "warnings" => "1.70"
+ },
+ "TEST_REQUIRES" => {
+ "Data::Printer" => "1.002001",
+ "Email::Sender::Transport::Test" => "2.601",
+ "Import::Into" => "1.002005",
+ "Net::DNS::Resolver::Mock" => "1.20230216",
+ "Path::Tiny" => "0.146",
+ "Test2::API" => "1.302209",
+ "Test2::V0" => "1.302209",
+ "URI" => "5.31",
+ "lib" => "0.65"
+ },
+ "VERSION" => "1.1.3",
+ "test" => {
+ "TESTS" => "t/*.t t/tests/*.t t/tests/sietima/*.t t/tests/sietima/multi-role/*.t t/tests/sietima/role/*.t t/tests/sietima/role/nospoof/*.t t/tests/sietima/role/subscriberonly/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Data::Printer" => "1.002001",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.954",
+ "Email::Sender::Simple" => "2.601",
+ "Email::Sender::Transport::Test" => "2.601",
+ "Email::Stuffer" => "0.020",
+ "Import::Into" => "1.002005",
+ "List::AllUtils" => "0.19",
+ "Mail::DMARC::PurePerl" => "1.20250203",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
+ "MooX::Traits" => "0.005",
+ "Net::DNS::Resolver::Mock" => "1.20230216",
+ "Path::Tiny" => "0.146",
+ "Test2::API" => "1.302209",
+ "Test2::V0" => "1.302209",
+ "Type::Library" => "2.006000",
+ "Type::Params" => "2.006000",
+ "Type::Utils" => "2.006000",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.006000",
+ "Types::URI" => "0.007",
+ "URI" => "5.31",
+ "feature" => "1.89",
+ "lib" => "0.65",
+ "namespace::clean" => "0.27",
+ "strict" => "1.13",
+ "warnings" => "1.70"
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);