aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL120
1 files changed, 57 insertions, 63 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4dc84f8..3c14d60 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,8 +1,8 @@
-# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.009.
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.030.
use strict;
use warnings;
-use 5.024;
+use 5.036000;
use ExtUtils::MakeMaker 7.30;
@@ -10,49 +10,46 @@ my %WriteMakefileArgs = (
"ABSTRACT" => "minimal mailing list manager",
"AUTHOR" => "Gianni Ceccarelli <dakkar\@thenautilus.net>",
"CONFIGURE_REQUIRES" => {
- "ExtUtils::MakeMaker" => "7.30"
+ "ExtUtils::MakeMaker" => "7.66"
},
"DISTNAME" => "Sietima",
"LICENSE" => "perl",
- "MIN_PERL_VERSION" => "5.024",
+ "MIN_PERL_VERSION" => "5.036000",
"NAME" => "Sietima",
"PREREQ_PM" => {
- "App::Spec" => ">= 0.004, != 0.004_001",
- "App::Spec::Run" => ">= 0.004, != 0.004_001",
- "Digest::SHA" => "5.96",
- "Email::Address" => "1.908",
- "Email::MIME" => "1.940",
- "Email::Sender" => "1.300031",
- "Email::Sender::Simple" => "1.300031",
- "Email::Stuffer" => "0.014",
- "List::AllUtils" => "0.14",
- "Moo" => "2.003002",
- "Moo::Role" => "2.003002",
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.953",
+ "Email::Sender::Simple" => "2.600",
+ "Email::Stuffer" => "0.020",
+ "List::AllUtils" => "0.19",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
"MooX::Traits" => "0.005",
- "Try::Tiny" => "0.28",
- "Type::Library" => "1.002001",
- "Type::Params" => "1.002001",
- "Type::Utils" => "1.002001",
- "Types::Path::Tiny" => "0.005",
- "Types::Standard" => "1.002001",
- "Types::URI" => "0.006",
- "experimental" => "0.016",
- "feature" => "1.42",
+ "Type::Library" => "2.002001",
+ "Type::Params" => "2.002001",
+ "Type::Utils" => "2.002001",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.002001",
+ "Types::URI" => "0.007",
+ "feature" => "1.72",
"namespace::clean" => "0.27",
- "strict" => "1.11",
- "warnings" => "1.36"
+ "strict" => "1.12",
+ "warnings" => "1.58"
},
"TEST_REQUIRES" => {
- "Data::Printer" => "0.39",
- "Email::Sender::Transport::Test" => "1.300031",
+ "Data::Printer" => "1.001000",
+ "Email::Sender::Transport::Test" => "2.600",
"Import::Into" => "1.002005",
- "Path::Tiny" => "0.104",
- "Test2::API" => "1.302086",
- "Test2::V0" => "0.000072",
- "URI" => "1.71",
- "lib" => "0.63"
+ "Path::Tiny" => "0.144",
+ "Test2::API" => "1.302192",
+ "Test2::V0" => "0.000145",
+ "URI" => "5.17",
+ "lib" => "0.65"
},
- "VERSION" => "1.0.3",
+ "VERSION" => "1.1.0",
"test" => {
"TESTS" => "t/*.t t/tests/*.t t/tests/sietima/*.t t/tests/sietima/multi-role/*.t t/tests/sietima/role/*.t t/tests/sietima/role/subscriberonly/*.t"
}
@@ -60,38 +57,35 @@ my %WriteMakefileArgs = (
my %FallbackPrereqs = (
- "App::Spec" => ">= 0.004, != 0.004_001",
- "App::Spec::Run" => ">= 0.004, != 0.004_001",
- "Data::Printer" => "0.39",
- "Digest::SHA" => "5.96",
- "Email::Address" => "1.908",
- "Email::MIME" => "1.940",
- "Email::Sender" => "1.300031",
- "Email::Sender::Simple" => "1.300031",
- "Email::Sender::Transport::Test" => "1.300031",
- "Email::Stuffer" => "0.014",
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Data::Printer" => "1.001000",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.953",
+ "Email::Sender::Simple" => "2.600",
+ "Email::Sender::Transport::Test" => "2.600",
+ "Email::Stuffer" => "0.020",
"Import::Into" => "1.002005",
- "List::AllUtils" => "0.14",
- "Moo" => "2.003002",
- "Moo::Role" => "2.003002",
+ "List::AllUtils" => "0.19",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
"MooX::Traits" => "0.005",
- "Path::Tiny" => "0.104",
- "Test2::API" => "1.302086",
- "Test2::V0" => "0.000072",
- "Try::Tiny" => "0.28",
- "Type::Library" => "1.002001",
- "Type::Params" => "1.002001",
- "Type::Utils" => "1.002001",
- "Types::Path::Tiny" => "0.005",
- "Types::Standard" => "1.002001",
- "Types::URI" => "0.006",
- "URI" => "1.71",
- "experimental" => "0.016",
- "feature" => "1.42",
- "lib" => "0.63",
+ "Path::Tiny" => "0.144",
+ "Test2::API" => "1.302192",
+ "Test2::V0" => "0.000145",
+ "Type::Library" => "2.002001",
+ "Type::Params" => "2.002001",
+ "Type::Utils" => "2.002001",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.002001",
+ "Types::URI" => "0.007",
+ "URI" => "5.17",
+ "feature" => "1.72",
+ "lib" => "0.65",
"namespace::clean" => "0.27",
- "strict" => "1.11",
- "warnings" => "1.36"
+ "strict" => "1.12",
+ "warnings" => "1.58"
);