summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGianni Ceccarelli <dakkar@dechirico.(none)>2009-05-10 14:02:31 +0200
committerGianni Ceccarelli <dakkar@dechirico.(none)>2009-05-10 14:02:31 +0200
commit23f29e4b2a147a738726b2846d8ef0290363ea2a (patch)
treea2d18e286f2744238afb047344046995bf1f14b8
parentinitial import (diff)
downloadgentoo-overlay-23f29e4b2a147a738726b2846d8ef0290363ea2a.tar.gz
gentoo-overlay-23f29e4b2a147a738726b2846d8ef0290363ea2a.tar.bz2
gentoo-overlay-23f29e4b2a147a738726b2846d8ef0290363ea2a.zip
added cgit ebuild
-rw-r--r--www-apps/cgit/Manifest5
-rw-r--r--www-apps/cgit/cgit-9999.ebuild64
-rw-r--r--www-apps/cgit/files/cgitrc84
-rw-r--r--www-apps/cgit/files/postinstall-en.txt3
4 files changed, 156 insertions, 0 deletions
diff --git a/www-apps/cgit/Manifest b/www-apps/cgit/Manifest
new file mode 100644
index 0000000..eaefa8a
--- /dev/null
+++ b/www-apps/cgit/Manifest
@@ -0,0 +1,5 @@
+AUX cgitrc 2066 RMD160 31d621fb653cf118d40cc3bfa9b159e80a1f3ee4 SHA1 7172623dd7844ae7fc0ef4fc8136b85a4bfc5f49 SHA256 c5fc42bb8514415eb93e4f6a07bf25622d7f3b4c7c9b19ce6523722b8b4b4b20
+AUX postinstall-en.txt 132 RMD160 d48bd3054fb61a275a8c46bd747ba52af73ebb36 SHA1 d8de0743cf3e44038be3c0017e55b43b4da2e4ae SHA256 e7966f520dacb50c2e38642f223caf2b3afbca913b4c99346b7f0286eeae8e26
+DIST git-1.5.5.1.tar.bz2 1675032 RMD160 943d6fe0e7d3e45893dde3c7b16880d56f76cd7e SHA1 a450cd02cbfe8e18311816a9568bcd6d10d6cf52 SHA256 c95156a12cd86a20420e037304c255c847d44353af8e0dc77ee074fc59248707
+EBUILD cgit-9999.ebuild 1317 RMD160 8b3e414a46cf124fcb136ec1f2cbd15d49be5c14 SHA1 8995ce5732687016f5ae09db686c0efdf691fd1e SHA256 9452c10a5c4253173a5c53d16d411c21a91f091dd7a34fe818ee5d4caf1bcbcc
+MISC cgit-9999.ebuild~ 1285 RMD160 ac57a52b6026decdc317f9a574ca3701029f5357 SHA1 00331ab0cd713e409fca3522aed96bb5509576fb SHA256 5a73693599e50f4aee2c15f8f12f9399eab9c5f7ee533a77cf2f6b0f668f3ee5
diff --git a/www-apps/cgit/cgit-9999.ebuild b/www-apps/cgit/cgit-9999.ebuild
new file mode 100644
index 0000000..de33543
--- /dev/null
+++ b/www-apps/cgit/cgit-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git webapp
+
+EGIT_REPO_URI="git://hjemli.net/pub/git/cgit"
+
+GIT_V="1.5.5.1"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://hjemli.net/git/cgit/about/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-util/git
+ sys-libs/zlib
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ git_src_unpack
+
+ # Extract the git release
+ unpack ${A}
+ cd "${S}"
+ rmdir git
+ mv git-${GIT_V} git
+ cp ${FILESDIR}/cgitrc .
+
+ sed -i \
+ -e "s:#css=/cgit/cgit.css:css=/cgit/cgit.css:" \
+ -e "s:#logo=/cgit/git-logo.png:logo=/cgit/cgit.png:" \
+ -e "s:#cache-root=/var/cache/cgit:cache-root=/var/cache/cgit:" \
+ cgitrc || die "patching cgitrc failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto ${MY_HTDOCSDIR}
+ mv cgit cgit.cgi
+ doins ${FILESDIR}/.htaccess cgit.cgi cgit.css cgit.png
+
+ insinto /etc
+ doins cgitrc
+
+ dodir /var/cache/cgit
+ keepdir /var/cache/cgit
+
+ # This is just plain wrong, how to do it correctly? (copied from bugzilla
+ # 3.0.4 ebuild)
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+
+ webapp_src_install
+}
diff --git a/www-apps/cgit/files/cgitrc b/www-apps/cgit/files/cgitrc
new file mode 100644
index 0000000..c73d064
--- /dev/null
+++ b/www-apps/cgit/files/cgitrc
@@ -0,0 +1,84 @@
+## Enable caching of up to 1000 output entriess
+cache-size=1000
+
+## Specify some default clone prefixes
+#clone-prefix=git://foobar.com ssh://foobar.com/pub/git http://foobar.com/git
+
+## Specify the css url
+css=/cgit/cgit.css
+
+## Show extra links for each repository on the index page
+enable-index-links=1
+
+## Show number of affected files per commit on the log pages
+enable-log-filecount=1
+
+## Show number of added/removed lines per commit on the log pages
+enable-log-linecount=1
+
+## Add a cgit favicon
+#favicon=/favicon.ico
+
+## Use a custom logo
+logo=/cgit/cgit.png
+
+## Set the title and heading of the repository index page
+#root-title=foobar.com git repositories
+
+## Set a subheading for the repository index page
+#root-desc=tracking the foobar development
+
+## Include some more info about foobar.com on the index page
+#root-readme=/var/www/htdocs/about.html
+
+## Allow download of tar.gz, tar.bz and zip-files
+snapshots=tar.gz tar.bz zip
+
+##
+## List of repositories.
+## PS: Any repositories listed when repo.group is unset will not be
+## displayed under a group heading
+## PPS: This list could be kept in a different file (e.g. '/etc/cgitrepos')
+## and included like this:
+## include=/etc/cgitrepos
+##
+
+#repo.url=foo
+#repo.path=/pub/git/foo.git
+#repo.desc=the master foo repository
+#repo.owner=fooman@foobar.com
+#repo.readme=info/web/about.html
+
+#repo.url=bar
+#repo.path=/pub/git/bar.git
+#repo.desc=the bars for your foo
+#repo.owner=barman@foobar.com
+#repo.readme=info/web/about.html
+
+## The next repositories will be displayed under the 'extras' heading
+#repo.group=extras
+
+#repo.url=baz
+#repo.path=/pub/git/baz.git
+#repo.desc=a set of extensions for bar users
+
+#repo.url=wiz
+#repo.path=/pub/git/wiz.git
+#repo.desc=the wizard of foo
+
+## Add some mirrored repositories
+#repo.group=mirrors
+
+#repo.url=git
+#repo.path=/pub/git/git.git
+#repo.desc=the dscm
+
+#repo.url=linux
+#repo.path=/pub/git/linux.git
+#repo.desc=the kernel
+
+## Disable adhoc downloads of this repo
+#repo.snapshots=0
+
+## Disable line-counts for this repo
+#repo.enable-log-linecount=0
diff --git a/www-apps/cgit/files/postinstall-en.txt b/www-apps/cgit/files/postinstall-en.txt
new file mode 100644
index 0000000..9102396
--- /dev/null
+++ b/www-apps/cgit/files/postinstall-en.txt
@@ -0,0 +1,3 @@
+You need to modify /etc/cgitrc with the list of available
+repositories. Look at the examples in the file by searching for
+repo.path