summaryrefslogtreecommitdiff
path: root/media-libs/qhull
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2020-03-27 13:16:38 +0000
committerdakkar <dakkar@thenautilus.net>2020-03-27 14:55:24 +0000
commit0d41052d7eb2d7e45d839b5e042bfc5d796f9750 (patch)
tree4a714f232299a1bd31a57b01688d02254daf2a82 /media-libs/qhull
parentand the manifest (diff)
downloadgentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.gz
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.bz2
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.zip
PrusaSlicer 2.2.0 and dependencies
there's apparently lots of new dependencies, or maybe newer versions are needed. I've added them to the PrusaSlicer ebuild, and added the ebuilds for them. Seems to work
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/Manifest3
-rw-r--r--media-libs/qhull/metadata.xml20
-rw-r--r--media-libs/qhull/qhull-2019.1.ebuild35
3 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/qhull/Manifest b/media-libs/qhull/Manifest
new file mode 100644
index 0000000..5844cb0
--- /dev/null
+++ b/media-libs/qhull/Manifest
@@ -0,0 +1,3 @@
+DIST qhull-2019.1.tar.gz 1236686 BLAKE2B 546f9a8784275239fbe94d1cc3c3f7ede8e4435c05221f9931fbe7bc085c20a306c335b8882deaa03292b49511726a417d75c86f14f7646693eb36bb93e03d30 SHA512 efcaf2af45f3c401f5f677cac8e3ffc056f870bf62f852982ca880282c428920fad13071017b8d8b7b6fc416380c6f3fe6973aa0b37a2322c234774325b14f1c
+EBUILD qhull-2019.1.ebuild 885 BLAKE2B e10b834d33075d5c31849d442fe80f5d245580cd7d4fc90a03956b0c1b181743cbb168602152ff28cc8143121403d812a5111491df62542bd232d7b7791b7cdd SHA512 253940dd62c99a0ac2e6449c514657e9bb1a0fe573c26be1bb267b261dcfff7cd4f93f63b987382e3b42f29ce2042a10f3280944cb7a469fe31f7d3c6cc9ea93
+MISC metadata.xml 977 BLAKE2B 57a86855387223c875830b8d60eb02f89f469dc4949f094255f43e0251cb537049d0a99a0eb9500c639730f6a0db518ec2b3a4ae050e3c9ea2f508cdbe790e98 SHA512 6e676d2faff561e67e077869a61747c834131ea67acb098497153c98d3bca38032ffa2ab57d6b612cfa4f1fbdb8b05b0c9a9132ab0cdeae5579bdac236b9a1f2
diff --git a/media-libs/qhull/metadata.xml b/media-libs/qhull/metadata.xml
new file mode 100644
index 0000000..c6a6929
--- /dev/null
+++ b/media-libs/qhull/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Qhull computes the convex hull, Delaunay triangulation, Voronoi
+ diagram, halfspace intersection about a point, furthest-site
+ Delaunay triangulation, and furthest-site Voronoi diagram. The
+ source code runs in 2-d, 3-d, 4-d, and higher dimensions. Qhull
+ implements the Quickhull algorithm for computing the convex hull. It
+ handles roundoff errors from floating point arithmetic. It computes
+ volumes, surface areas, and approximations to the convex hull.
+ Qhull does not support constrained Delaunay triangulations,
+ triangulation of non-convex surfaces, mesh generation of non-convex
+ objects, or medium-sized inputs in 9-D and higher.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/qhull/qhull-2019.1.ebuild b/media-libs/qhull/qhull-2019.1.ebuild
new file mode 100644
index 0000000..57c7763
--- /dev/null
+++ b/media-libs/qhull/qhull-2019.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="http://www.qhull.org/download/${PN}-2019-src-7.3.2.tgz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ mycmakeargs+=(
+ -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
+ -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${P}/html
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # compatibility with previous installs
+ dosym libqhull /usr/include/qhull
+ if ! use doc; then
+ rm -rf "${ED}"/usr/share/doc/${P}/html || die
+ fi
+}