summaryrefslogtreecommitdiff
path: root/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild')
-rw-r--r--app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild b/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
new file mode 100644
index 0000000..dba28a9
--- /dev/null
+++ b/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
@@ -0,0 +1,32 @@
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-server/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/json-c
+ dev-libs/check"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+}