summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/Manifest2
-rw-r--r--mail-client/claws-mail/claws-mail-3.17.4-r2.ebuild233
2 files changed, 235 insertions, 0 deletions
diff --git a/mail-client/claws-mail/Manifest b/mail-client/claws-mail/Manifest
index a9e9425..aea43e6 100644
--- a/mail-client/claws-mail/Manifest
+++ b/mail-client/claws-mail/Manifest
@@ -1,4 +1,6 @@
DIST claws-mail-3.16.0.tar.xz 5913948 BLAKE2B 6744045de6bc3945221569a9ae1cdcd849ec11c4f5dbfe966ca70c7c2ab3f5d9ded1dbd5bcedffdc756809c1802d31d955b5c6c53f20a00be5abc861db340d0f SHA512 5c96e21b4c5117b67ccfe4178c68e2f1b1449f882d6ecf22041e41f08fd607c6ce7afe6c7fdbd039da7ffc5673d366551b15d3e4b7de8d758fc1554a8eadc55e
DIST claws-mail-3.17.3.tar.xz 6164392 BLAKE2B ac0781c4c7e4423f4a8b494a9bd007d62443e8c540feaeef089ca65f641da5ecabfa2c5c0662750d6f58c8913c1d95750a3dfb6b4628e573b0105f8f526bc066 SHA512 b562d785eaedbdec408c4a3db8f4d9326183266fe314509a189c9e1220f15b4f41ccd9d8c58c5194c0267842e8efe900e88eb17c0d17d6069e2543870efa5ef8
+DIST claws-mail-3.17.4.tar.xz 6280252 BLAKE2B 8ddce2e5dfb3ae0ddb646c4f5a81d7e4c3834d2fa7a7f7a7326bf6e160291db4ba5954737bb61a4ae86ebaaab72a695d2e351fe2cf89b187eba4341f5d9b0cd9 SHA512 4fc3b04d89c84b068654902d3d4f8ba66ec86c4ea9c4bd145fb3169dd26a2fcfc26adc8367b0ed90c69d095f6b1717ba3a9a52cc6d3e310a9dad1c3f733d8012
EBUILD claws-mail-3.16.0-r1.ebuild 5777 BLAKE2B d084449f64e398a14d0c54aea638de69cb43b5ae5586e1e2922d2b47226419a3eee775f4cda1369032f15d82873985e275be05b405b10a6353bd429da2908cc7 SHA512 3504ded01e631cdef10a39713bd929ee3fb158b30ace4d0e26113d8d73dda681a3d8a2ca168f43dd52864503decf6a8d1813422192dee955e236e80d07dc8af2
EBUILD claws-mail-3.17.3-r2.ebuild 5952 BLAKE2B d357f4d6ebd350d83d41909c8e9e8e75364926c13ac991dcbca36f3282ad83a60d1361b4165bad50be4156fff468794f99eadb0b35e8f781e69a16e9fb1fcb2f SHA512 0811773f38106ce9807d1514b589be2daa3b7d2767a5fced812bc9ffb234f0114d5f30928762a2411cbda9dc09f3541e259f306490c150d1c635c4ba565874e4
+EBUILD claws-mail-3.17.4-r2.ebuild 6189 BLAKE2B 9487f1dd2a83a7791dee710bb6ffb6bc34208a69c27b06bd8736f6916d6f5b402040aa48243ece14fe9e3957839a865f841b2c096652331edb41c5c3335febd0 SHA512 8d07e3509cc45b777cbec969e44bb6a43e08f38f604593a761ed4d28a479130bc6be187de1ac1d5b65df5c9c09dc0715366d04cc38f4d8e151b3272146f2fb1c
diff --git a/mail-client/claws-mail/claws-mail-3.17.4-r2.ebuild b/mail-client/claws-mail/claws-mail-3.17.4-r2.ebuild
new file mode 100644
index 0000000..f7d6702
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.17.4-r2.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools desktop python-single-r1 xdg
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="https://www.claws-mail.org/"
+
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.claws-mail.org/claws.git"
+else
+ SRC_URI="https://www.claws-mail.org/download.php?file=releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls +imap ipv6 ldap +libcanberra +libindicate +libnotify litehtml networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind webkit xface"
+
+REQUIRED_USE="libcanberra? ( notification )
+ libindicate? ( notification )
+ libnotify? ( notification )
+ networkmanager? ( dbus )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ smime? ( pgp )"
+
+COMMONDEPEND="
+ dev-libs/nettle:=
+ net-mail/ytnef
+ sys-libs/zlib:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2[jpeg]
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ x11-libs/pango
+ archive? (
+ app-arch/libarchive
+ >=net-misc/curl-7.9.7
+ )
+ bogofilter? ( mail-filter/bogofilter )
+ calendar? (
+ >=dev-libs/libical-2.0.0:=
+ >=net-misc/curl-7.9.7
+ )
+ dbus? (
+ >=dev-libs/dbus-glib-0.60
+ sys-apps/dbus
+ )
+ gdata? ( >=dev-libs/libgdata-0.17.2 )
+ dillo? ( www-client/dillo )
+ gnutls? ( >=net-libs/gnutls-3.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ litehtml? (
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/gumbo-0.10
+ net-misc/curl
+ media-libs/fontconfig
+ )
+ nls? ( >=sys-devel/gettext-0.18 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ notification? (
+ dev-libs/glib:2
+ libcanberra? ( media-libs/libcanberra[gtk] )
+ libindicate? ( dev-libs/libindicate:3[gtk] )
+ libnotify? ( x11-libs/libnotify )
+ )
+ pda? ( >=app-pda/jpilot-0.99 )
+ pdf? ( app-text/poppler[cairo] )
+ pgp? ( >=app-crypt/gpgme-1.0.0 )
+ session? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ smime? ( >=app-crypt/gpgme-1.0.0 )
+ spam-report? ( >=net-misc/curl-7.9.7 )
+ spell? ( >=app-text/enchant-1.0.0:= )
+ startup-notification? ( x11-libs/startup-notification )
+ svg? ( >=gnome-base/librsvg-2.40.5 )
+ valgrind? ( dev-util/valgrind )
+ webkit? ( >=net-libs/webkit-gtk-1.1.14:2 )
+"
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info
+ clamav? ( app-antivirus/clamav )
+ networkmanager? ( net-misc/networkmanager )
+ pdf? ( app-text/ghostscript-gpl )
+ perl? ( dev-lang/perl:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3
+ )
+ rss? (
+ dev-libs/libxml2
+ net-misc/curl
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libetpan_pkgconfig.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # Don't use libsoup-gnome (bug #565924)
+ export HAVE_LIBSOUP_GNOME=no
+
+ local myeconfargs=(
+ --disable-bsfilter-plugin
+ --disable-generic-umpc
+ --enable-acpi_notifier-plugin
+ --enable-address_keeper-plugin
+ --enable-alternate-addressbook
+ --enable-att_remover-plugin
+ --enable-attachwarner-plugin
+ --enable-fetchinfo-plugin
+ --enable-mailmbox-plugin
+ --enable-newmail-plugin
+ --enable-tnef_parse-plugin
+ --with-password-encryption=$(usex gnutls gnutls old)
+ $(use_enable archive archive-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable calendar vcalendar-plugin)
+ $(use_enable clamav clamd-plugin)
+ $(use_enable dbus)
+ $(use_enable debug crash-dialog)
+ $(use_enable dillo dillo-plugin)
+ $(use_enable doc manual)
+ $(use_enable gdata gdata-plugin)
+ $(use_enable gnutls)
+ $(use_enable ipv6)
+ $(use_enable ldap)
+ $(use_enable litehtml litehtml_viewer-plugin)
+ $(use_enable networkmanager)
+ $(use_enable nls)
+ $(use_enable notification notification-plugin)
+ $(use_enable pda jpilot)
+ $(use_enable pdf pdf_viewer-plugin)
+ $(use_enable perl perl-plugin)
+ $(use_enable pgp pgpcore-plugin)
+ $(use_enable pgp pgpinline-plugin)
+ $(use_enable pgp pgpmime-plugin)
+ $(use_enable python python-plugin)
+ $(use_enable rss rssyl-plugin)
+ $(use_enable session libsm)
+ $(use_enable sieve managesieve-plugin)
+ $(use_enable smime smime-plugin)
+ $(use_enable spam-report spam_report-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable spell enchant)
+ $(use_enable startup-notification)
+ $(use_enable svg)
+ $(use_enable valgrind valgrind)
+ $(use_enable webkit fancy-plugin)
+ $(use_enable xface compface)
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp ; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ default
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png
+ local size
+ for size in 64 128 ; do
+ newicon -s ${size} ${PN}-${size}x${size}.png ${PN}.png
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools || die
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh
+ doexe tb2claws-mail update-po uudec uuooffice
+
+ # kill useless files
+ rm -f "${ED}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+ ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+ ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+ ewarn "- The gtkhtml2 and trayicon plugins have been dropped entirely"
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}