summaryrefslogtreecommitdiff
path: root/media-gfx
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openvdb/Manifest3
-rw-r--r--media-gfx/openvdb/metadata.xml28
-rw-r--r--media-gfx/openvdb/openvdb-7.0.0.ebuild71
3 files changed, 0 insertions, 102 deletions
diff --git a/media-gfx/openvdb/Manifest b/media-gfx/openvdb/Manifest
deleted file mode 100644
index cd14b32..0000000
--- a/media-gfx/openvdb/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST openvdb-7.0.0.tar.gz 1872744 BLAKE2B e3a8c8d51f77e115d3d397abde0860a6322d56eb6c4795c1ba39539a23aab6cf37602ce7122965fbc3098b15b118b25010263f567e8003363b78c9b7d9d5dfd8 SHA512 f5321b22b10e192012d544cc02921d3d52f621778ec5aa21ba6d450f3e29f2fdbd76486ad390a0c008394dbc6ee4aeecc04527ef30e73adf71c1a08a021746b7
-EBUILD openvdb-7.0.0.ebuild 1666 BLAKE2B d74ba3bbaa405016bc2e7b8224e1c6495efd5d1e0562db5ebf071d6d2d41d2d220a1382d6d244d08294417aba55805c80af6df8393e4f8d5316b8f7e85afba88 SHA512 e18e3fd13624fde1515fd8df52f8eed219777542dabf282154c8ff4857721d39787b30e650ee4330caf45dc4145401a04cf84c13e500bb25941e24a77344255d
-MISC metadata.xml 1033 BLAKE2B 303f49be8253322a0bbb94875f7b9b03e127e9d2ab2eea64fbac1cd51f50d5be749c4c45c9491fbf3f56de7420fdb47913b6ef3c2d12f5ea0545042f68d990d4 SHA512 a81a1cd4684197d1d9455b1398c9ba1592d596d52c8e8fc5c0cc8de0357c1f1df7478fd76e4e42cda09524b0bbf41985e13cf530adb7ca7f1605f086207301a8
diff --git a/media-gfx/openvdb/metadata.xml b/media-gfx/openvdb/metadata.xml
deleted file mode 100644
index 7470615..0000000
--- a/media-gfx/openvdb/metadata.xml
+++ /dev/null
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>agrigo2001@yahoo.com.au</email>
- <name>Adrian Grigo</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription>
- Libraries from Dreamworks Animation for the efficient manipulation
- of volumetric data used in big budget movies like 'Cloudy with a
- Chance of Meatballs2' and 'How to Train Your Dragon 2'.
- </longdescription>
- <use>
- <flag restrict="&lt;media-gfx/openvdb-5.0.0" name="abi3-compat">
- Disables newer features to maintain compatibility with ABI3. Enabled by default.
- </flag>
- <flag restrict="&gt;=media-gfx/openvdb-5.0.0" name="abi4-compat">
- Disables newer features to maintain compatibility with ABI4. Enabled by default.
- </flag>
- </use>
- <upstream>
- <remote-id type="github">dreamworksanimation/openvdb</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-gfx/openvdb/openvdb-7.0.0.ebuild b/media-gfx/openvdb/openvdb-7.0.0.ebuild
deleted file mode 100644
index c7f8dd8..0000000
--- a/media-gfx/openvdb/openvdb-7.0.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-utils flag-o-matic python-single-r1
-
-DESCRIPTION="Libs for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc python test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=dev-libs/boost-1.62:=
- >=dev-libs/c-blosc-1.5.0
- dev-libs/jemalloc
- dev-libs/log4cplus
- media-libs/glfw:=
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-libs/boost-1.62:=[python,${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')
- )"
-
-DEPEND="${RDEPEND}
- dev-cpp/tbb
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_NO_SYSTEM_FROM_IMPORTED=true
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_RPATH=OFF
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
-
- cmake-utils_src_configure
-}