summaryrefslogtreecommitdiff
path: root/media-libs/openexr/openexr-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openexr/openexr-2.4.1.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/openexr/openexr-2.4.1.ebuild b/media-libs/openexr/openexr-2.4.1.ebuild
new file mode 100644
index 0000000..c16fbcc
--- /dev/null
+++ b/media-libs/openexr/openexr-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/openexr/openexr/archive/v${PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 -arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="sys-libs/zlib
+ !media-libs/ilmbase"
+
+RESTRICT="test" # Tests broken upstream doesn't really care about them, bug #656680
+
+DOCS=( CHANGES.md README.md )
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}