summaryrefslogtreecommitdiff
path: root/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
index 769f4ff..db194ed 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby24 ruby25 ruby26"
inherit autotools check-reqs flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs versionator virtualx
@@ -196,14 +196,14 @@ src_configure() {
local ruby_interpreter=""
- if has_version "virtual/rubygems[ruby_targets_ruby23]"; then
- ruby_interpreter="RUBY=$(type -P ruby23)"
- elif has_version "virtual/rubygems[ruby_targets_ruby22]"; then
- ruby_interpreter="RUBY=$(type -P ruby22)"
- elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
- ruby_interpreter="RUBY=$(type -P ruby21)"
+ if has_version "virtual/rubygems[ruby_targets_ruby26]"; then
+ ruby_interpreter="RUBY=$(type -P ruby26)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby25]"; then
+ ruby_interpreter="RUBY=$(type -P ruby25)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby24]"; then
+ ruby_interpreter="RUBY=$(type -P ruby24)"
else
- ruby_interpreter="RUBY=$(type -P ruby20)"
+ ruby_interpreter="RUBY=$(type -P ruby24)"
fi
# TODO: Check Web Audio support