summaryrefslogtreecommitdiff
path: root/sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild')
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild b/sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild
new file mode 100644
index 0000000..22145f7
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.0.3.ebuild
@@ -0,0 +1,28 @@
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) PAM module"
+HOMEPAGE="https://developers.yubico.com/pam-u2f/"
+SRC_URI="https://developers.yubico.com/pam-u2f/Releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ app-crypt/libu2f-server"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+}