aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAge
...
* Little bits of glue to make the Model01 Firwmare into a 'real' arduino ↵Jesse Vincent2017-10-03
| | | | library that the IDE doesn't hate
* update to shifttolayer and instead of the old keymap_n_momentary macros;Jesse Vincent2017-10-03
| | | | update doc
* Merge pull request #15 from martinakcsilla/use-does-not-need-sentinelJesse Vincent2017-10-03
|\ | | | | Remove the NULL from the end of Kaleidoscope.use
| * Remove the NULL from the end of Kaleidoscope.useCsilla Nagyné Martinák2017-10-03
|/ | | | | | | | For a while now, `Kaleidoscope.use` does not require a NULL sentinel at the end. This drops the sentinel instead of adding documentation that would explain why that NULL is there. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* clean up indentation of keymapsJesse Vincent2017-10-02
|
* remove the special NUMPAD_ID definition; move the keymap definitions into ↵Jesse Vincent2017-10-02
| | | | | | the variable declaration. This has the advantage of having one fewer construct to explain
* Doc updates as suggested by @cdisselkoen++Jesse Vincent2017-10-02
|
* add notes about updating firmware and libraries to the READMEJesse Vincent2017-10-02
|
* Slightly simplify the default keymaps, removing some duplicationJesse Vincent2017-10-02
|
* Close a commentJesse Vincent2017-10-02
|
* astyleJesse Vincent2017-10-02
|
* First pass at comments on the rest of the default sketchJesse Vincent2017-10-02
|
* comment much of the default sketchJesse Vincent2017-10-02
|
* We're not actually exposing BootKeyboard yet.Jesse Vincent2017-10-02
|
* Move some LED color definitions to after the macro defnitions.Jesse Vincent2017-10-02
| | | | It seems a little clearer.
* move the hopefully-going-away numpad keymap id definition closer toJesse Vincent2017-10-02
| | | | where one can intuit why it's that number
* reorganize imports for a little more clarityJesse Vincent2017-10-02
|
* whitespaceJesse Vincent2017-10-02
|
* Refactor macro code to remove hand-coded numbers and make code a bit more ↵Jesse Vincent2017-10-02
| | | | readable
* astyleJesse Vincent2017-10-02
|
* Remove a couple of C preprocessor macros involved in the definition ofJesse Vincent2017-10-02
| | | | keyboard macros, in the hope of making the code clearer
* DEBUG_SERIAL is unused. kill itJesse Vincent2017-10-02
|
* replace a magic seeming constant with a macroJesse Vincent2017-10-02
|
* decompose a conditional to make it easier to read and refactorJesse Vincent2017-10-02
|
* Kaleidoscope.setup no longer takes an argumentJesse Vincent2017-10-02
|
* change the name of a compiler macro to make it clear that it's an idJesse Vincent2017-10-02
|
* rename our keymaps to be more consistent.Jesse Vincent2017-10-02
| | | | | | I feel weird about putting the name before the word 'keymap', but this seems less confusing than explaining why KEYMAP_QWERTY and KEYMAP_STACKED are different kidns of entitites
* Merge pull request #14 from algernon/f/numlock-no-macroJesse Vincent2017-10-02
|\ | | | | Updated to use the new NumLock plugin.
| * Updated to use the new NumLock pluginGergely Nagy2017-10-01
| | | | | | | | | | | | | | The NumLock plugin works without a macro now, so we can simplify the factory firmware by just using `Key_KeypadNumLock`. Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add some notes to the end of the readme. Thanks to @Jennigma++Jesse Vincent2017-10-02
|/
* A couple explanatory notes suggested by Jennifer LeighJesse Vincent2017-09-08
|
* Merge pull request #13 from cdisselkoen/improved-flashing-docsGergely Nagy2017-08-27
|\ | | | | Improve documentation related to flashing
| * Improve documentation related to flashingCraig Disselkoen2017-08-24
|/ | | | In particular, add instructions for the Arduino IDE
* Point Makefile to new make rulesJesse Vincent2017-08-21
|
* Merge pull request #12 from algernon/f/led-api-updateGergely Nagy2017-08-17
|\ | | | | Updated to use the new LEDMode/LEDControl APIs
| * Updated to use the new LEDMode/LEDControl APIsGergely Nagy2017-08-16
| | | | | | | | Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add a note about customizing the location of the Arduino install on LinuxJesse Vincent2017-08-16
| |
* | slight makefile tweaksJesse Vincent2017-08-16
| |
* | a bit more tweaking to the readmeJesse Vincent2017-08-16
| |
* | Reorganize makefile to avoid suggestions that Arduino lets you customizeJesse Vincent2017-08-16
| | | | | | | | your sketchbook directory
* | fix a path in the makefileJesse Vincent2017-08-16
| |
* | fix rendering of READMEJesse Vincent2017-08-16
| |
* | A pass at cleaning up the install instructions and Makefile a bitJesse Vincent2017-08-16
|/
* astylev1.13v1.12v1.11Jesse Vincent2017-08-13
|
* We had the wrong key definition for what keyboards actually use as thev1.10Jesse Vincent2017-08-13
| | | | 'menu'
* First pass at adding in the boot greeting plugin to make the LED keyJesse Vincent2017-08-13
| | | | glow on boot
* Switch our mute key to Key_Mute in the hope that it works better on OSXJesse Vincent2017-08-07
|
* Merge pull request #9 from algernon/h/fn-fn-numpad-lock-be-goneJesse Vincent2017-08-03
|\ | | | | Turn the Fn keys into Keymap1_Momentary
| * Turn the Fn keys into Keymap1_MomentaryGergely Nagy2017-07-30
|/ | | | | | | | | | | | | | | When both `Fn` keys are `KeymapNext_Momentary`, holding both would get us to the `NUMPAD` layer, which overrides the palm keys and turns them into `Keymap1_Momentary` keys. Thus, when releasing them, we would receive a release event for `Keymap1_Momentary`, not for `KeymapNext_Momentary`, and we'd be stuck on the `Numpad` layer until toggling it off. To avoid this scenario, change the `KeymapNext_Momentary` keys into `Keymap1_Momentary`, so we never reach the `NUMPAD` layer via the `Fn` keys. Fixes keyboardio/Kaleidoscope#151, with thanks to @chughes87 for the report! Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* Merge pull request #7 from algernon/h/readme-fixupsJesse Vincent2017-07-27
|\ | | | | Small README fixups