aboutsummaryrefslogtreecommitdiff
path: root/Model01-Firmware.ino
Commit message (Collapse)AuthorAge
* Now that 'Consumer_Mute' is no longer blocked by 'is_internal', we canv1.22Jesse Vincent2017-11-13
| | | | | switch back to using it, to get a working mute toggle on linux, windows and osx.
* astyle fixesJesse Vincent2017-11-13
|
* Swap the order of the Numpad and Fn layers, so it's possible to get toJesse Vincent2017-11-13
| | | | arrow keys if you have the numpad on.
* Switch from the NumLock library to the NumPad library.Jesse Vincent2017-11-12
| | | | | | This new plugin lets us use a more standard layer lock to get into the numpad mode and doesn't depend on the system numlock feature quite as much
* Added a couple "to be documented" itemsJennifer Leigh2017-10-04
| | | | | | | I added a couple items to the list of things that should be documented. I also realize I have no idea what the ANY key does, but I'm intrigued. I don't understand from these code comments, and don't have time to puzzle it out now. Otherwise, though, this is so much better than the file I've been poking at for weeks! It's clear and clean and much more welcoming. Thanks for all the behind the scenes work that made this possible, and thank you Jesse for the work writing up comments!
* Make the sketch use backslash lessCsilla Nagyné Martinák2017-10-04
| | | | | | | This lass is not fond of backslash, so she made the sketch use backslash less, so much so that it is now backslash-less. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* Fix misleading indentation in all three layers' keymapsCraig Disselkoen2017-10-03
| | | | plus add astyle directives to make astyle not complain about it
* update to shifttolayer and instead of the old keymap_n_momentary macros;Jesse Vincent2017-10-03
| | | | update doc
* Remove the NULL from the end of Kaleidoscope.useCsilla Nagyné Martinák2017-10-03
| | | | | | | | For a while now, `Kaleidoscope.use` does not require a NULL sentinel at the end. This drops the sentinel instead of adding documentation that would explain why that NULL is there. Signed-off-by: Csilla Nagyné Martinák <csilla@csillger.hu>
* clean up indentation of keymapsJesse Vincent2017-10-02
|
* remove the special NUMPAD_ID definition; move the keymap definitions into ↵Jesse Vincent2017-10-02
| | | | | | the variable declaration. This has the advantage of having one fewer construct to explain
* Doc updates as suggested by @cdisselkoen++Jesse Vincent2017-10-02
|
* Slightly simplify the default keymaps, removing some duplicationJesse Vincent2017-10-02
|
* Close a commentJesse Vincent2017-10-02
|
* astyleJesse Vincent2017-10-02
|
* First pass at comments on the rest of the default sketchJesse Vincent2017-10-02
|
* comment much of the default sketchJesse Vincent2017-10-02
|
* We're not actually exposing BootKeyboard yet.Jesse Vincent2017-10-02
|
* Move some LED color definitions to after the macro defnitions.Jesse Vincent2017-10-02
| | | | It seems a little clearer.
* move the hopefully-going-away numpad keymap id definition closer toJesse Vincent2017-10-02
| | | | where one can intuit why it's that number
* reorganize imports for a little more clarityJesse Vincent2017-10-02
|
* whitespaceJesse Vincent2017-10-02
|
* Refactor macro code to remove hand-coded numbers and make code a bit more ↵Jesse Vincent2017-10-02
| | | | readable
* astyleJesse Vincent2017-10-02
|
* Remove a couple of C preprocessor macros involved in the definition ofJesse Vincent2017-10-02
| | | | keyboard macros, in the hope of making the code clearer
* DEBUG_SERIAL is unused. kill itJesse Vincent2017-10-02
|
* replace a magic seeming constant with a macroJesse Vincent2017-10-02
|
* decompose a conditional to make it easier to read and refactorJesse Vincent2017-10-02
|
* Kaleidoscope.setup no longer takes an argumentJesse Vincent2017-10-02
|
* change the name of a compiler macro to make it clear that it's an idJesse Vincent2017-10-02
|
* rename our keymaps to be more consistent.Jesse Vincent2017-10-02
| | | | | | I feel weird about putting the name before the word 'keymap', but this seems less confusing than explaining why KEYMAP_QWERTY and KEYMAP_STACKED are different kidns of entitites
* Updated to use the new NumLock pluginGergely Nagy2017-10-01
| | | | | | | The NumLock plugin works without a macro now, so we can simplify the factory firmware by just using `Key_KeypadNumLock`. Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* Updated to use the new LEDMode/LEDControl APIsGergely Nagy2017-08-16
| | | | Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* astylev1.13v1.12v1.11Jesse Vincent2017-08-13
|
* We had the wrong key definition for what keyboards actually use as thev1.10Jesse Vincent2017-08-13
| | | | 'menu'
* First pass at adding in the boot greeting plugin to make the LED keyJesse Vincent2017-08-13
| | | | glow on boot
* Switch our mute key to Key_Mute in the hope that it works better on OSXJesse Vincent2017-08-07
|
* Turn the Fn keys into Keymap1_MomentaryGergely Nagy2017-07-30
| | | | | | | | | | | | | | | When both `Fn` keys are `KeymapNext_Momentary`, holding both would get us to the `NUMPAD` layer, which overrides the palm keys and turns them into `Keymap1_Momentary` keys. Thus, when releasing them, we would receive a release event for `Keymap1_Momentary`, not for `KeymapNext_Momentary`, and we'd be stuck on the `Numpad` layer until toggling it off. To avoid this scenario, change the `KeymapNext_Momentary` keys into `Keymap1_Momentary`, so we never reach the `NUMPAD` layer via the `Fn` keys. Fixes keyboardio/Kaleidoscope#151, with thanks to @chughes87 for the report! Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* astyleJesse Vincent2017-07-25
|
* Fix key repeat on Any. Port to new hid facade apiJesse Vincent2017-07-25
|
* switch to new CamelCased' toggle functionsJesse Vincent2017-07-24
|
* Update to work with an argument-less NumLock.toggle()Gergely Nagy2017-07-02
| | | | Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* move the rainbow effects earlier in the effect listv1.02Jesse Vincent2017-06-19
|
* brighten up the rainbow effectsv1.01Jesse Vincent2017-06-12
|
* Move the version key to "any" on the numlock layerv1.0Jesse Vincent2017-06-12
|
* Macro.type needs PSTR() macros around strings.Jesse Vincent2017-06-11
| | | | Algernon talked me out of putting the newline in the macro
* That's a stacked keymapJesse Vincent2017-06-10
|
* Update the versioning macro to hopefully pull verison info in from the build ↵Jesse Vincent2017-06-09
| | | | system
* Call Macros "Macro_blah" rather than "Key_blah"Jesse Vincent2017-06-09
|
* Update mouse buttons to match the printed layout cardsJesse Vincent2017-06-07
|