aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-02-02 22:35:20 -0800
committerPeter Hutterer <peter.hutterer@who-t.net>2009-02-03 19:56:45 +1000
commit0f0743e3cfc2f7d288dfec3fba9bc093cbedf537 (patch)
tree7fcf63a9c3d3bbd8cb1dbe1f56b552f70b7c85c3 /Makefile.am
parentJanitor: make distcheck, .gitignore. (diff)
downloadxf86-input-evdev-0f0743e3cfc2f7d288dfec3fba9bc093cbedf537.tar.gz
xf86-input-evdev-0f0743e3cfc2f7d288dfec3fba9bc093cbedf537.tar.bz2
xf86-input-evdev-0f0743e3cfc2f7d288dfec3fba9bc093cbedf537.zip
Really fix distcheck
distcheck has an annoying feature where it checks that all files install under $prefix. Unfortunately, this conflicts with the desire to install headers to the SDK directory. Workaround by passing --with-sdkdir during distcheck. Signed-off-by: Dan Nicholson <dbn.lists@gmail.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a59a65..54814c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,9 @@
AUTOMAKE_OPTIONS = foreign
+# Ensure headers are installed below $(prefix) for distcheck
+DISTCHECK_CONFIGURE_FLAGS = --with-sdkdir='$${includedir}/xorg'
+
if BUILD_TEST
test_dir=test
endif