aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@redhat.com>2008-10-29 16:54:16 +1030
committerPeter Hutterer <peter.hutterer@redhat.com>2008-10-30 16:51:55 +1030
commitd5cf24d3f0075a467e026592bfbb76b207dea8eb (patch)
treef47fcb6e72a6d087b40731376835569a36dd02e0 /Makefile.am
parentTreat BTN_[0-2] as LMR buttons if necessary. (diff)
downloadxf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.gz
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.bz2
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.zip
Add test/ directory for uinput-based test devices.
Three test devices provided: btn0 .... Provides BTN_0, BTN_1, BTN_2 instead of BTN_LEFT, BTN_MIDDLE, BTN_RIGHT. abs ..... Provdes x/y absolute axes, jumps between 100/100 and 120/120. absrel .. Provides relative x/y axes and absolute x/y axes at the same time. Signed-off-by: Peter Hutterer <peter.hutterer@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 99f7160..d8397f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,12 @@
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = src man include
+
+if BUILD_TEST
+test_dir=test
+endif
+
+SUBDIRS = src man include $(test_dir)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xorg-evdev.pc