aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@nwnk.net>2005-07-12 06:15:08 +0000
committerAdam Jackson <ajax@nwnk.net>2005-07-12 06:15:08 +0000
commit29621860ab38f318d8b19551391ac7997b8af2de (patch)
treecee943c721f7b64f3fd18af287dc9f3569c391f5 /configure.ac
parentPrep input drivers for modularizing by adding guarded #include "config.h" (diff)
downloadxf86-input-evdev-29621860ab38f318d8b19551391ac7997b8af2de.tar.gz
xf86-input-evdev-29621860ab38f318d8b19551391ac7997b8af2de.tar.bz2
xf86-input-evdev-29621860ab38f318d8b19551391ac7997b8af2de.zip
Build skeletons for input drivers. Should basically work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac80
1 files changed, 80 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f15f51d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,80 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+#
+# Process this file with autoconf to produce a configure script
+
+AC_PREREQ(2.57)
+AC_INIT([xf86-input-evdev],
+ 0.1.0,
+ [ajax@freedesktop.org],
+ xf86-input-evdev)
+
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_MAINTAINER_MODE
+
+DRIVER_NAME=evdev
+AC_SUBST([DRIVER_NAME])
+
+AM_CONFIG_HEADER([config.h])
+AC_CONFIG_AUX_DIR(.)
+
+# Checks for programs.
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+AH_TOP([#include "xorg-server.h"])
+
+#AC_DEFINE(XFree86LOADER,1,[Stub define for loadable drivers])
+#
+#AC_ARG_ENABLE(XINPUT, AS_HELP_STRING([--enable-xinput],
+# [Build XInput support (default: yes)]),
+# [XINPUT=$enableval],[XINPUT=yes])
+#AM_CONDITIONAL(XINPUT, test "x$XINPUT" = "xyes")
+#if test "x$XINPUT" = "xyes" ; then
+# AC_DEFINE(XINPUT,1,[Enable XInput support])
+#fi
+#
+#AC_ARG_ENABLE(XKB, AS_HELP_STRING([--enable-xkb],
+# [Build XKB support (default: yes)]),
+# [XKB=$enableval],[XKB=yes])
+#AM_CONDITIONAL(XKB, test "x$XKB" = "xyes")
+#if test "x$XKB" = "xyes" ; then
+# AC_DEFINE(XKB,1,[Enable XKB support])
+#fi
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XORG, xorg-server)
+inputdir=$(pkg-config --variable=moduledir xorg-server)/input
+AC_SUBST([inputdir])
+sdkdir=$(pkg-config --variable=sdkdir xorg-server)
+
+CFLAGS="$XORG_CFLAGS "' -I$(top_srcdir)/src'
+INCLUDES="$XORG_INCS -I${sdkdir} "'-I$(top_srcdir)/src -I$(prefix)/include'
+AC_SUBST([CFLAGS])
+AC_SUBST([INCLUDES])
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+
+AC_OUTPUT([Makefile src/Makefile man/Makefile])