aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-04-17 15:11:43 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-04-19 08:52:07 -0400
commitb31c00efeaa0e3c75c0ab35458aaa322719a823f (patch)
tree039a42b94c9f6344baab668dee1d3adb11c61e7e /configure.ac
parentconfig: replace deprecated INCLUDES with AM_CPPFLAGS (diff)
downloadxf86-input-evdev-b31c00efeaa0e3c75c0ab35458aaa322719a823f.tar.gz
xf86-input-evdev-b31c00efeaa0e3c75c0ab35458aaa322719a823f.tar.bz2
xf86-input-evdev-b31c00efeaa0e3c75c0ab35458aaa322719a823f.zip
config: optional extension check for inputproto not required
The check should be in PKG_CHECK_MODULES permanently. The XORG_DRIVER_CHECK_EXT will add inputproto to PKG_CHECK_MODULES only if the extension is available. By definition, this extension is always available and the evdev driver cannot function without it. This is evidenced by the absence of XINPUT conditional code. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7213f73..e2a9418 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,12 +53,9 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
-# Checks for extensions
-XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
-
# Checks for pkg-config packages. We need to be able to override sdkdir
# to satisfy silly distcheck requirements.
-PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)
+PKG_CHECK_MODULES(XORG, xorg-server xproto inputproto)
# Checks for libraries.