aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChase Douglas <chase.douglas@canonical.com>2010-11-08 14:35:02 -0500
committerPeter Hutterer <peter.hutterer@who-t.net>2011-11-11 15:50:36 +1000
commitc9a2b4e9ce9b15e57241184df78c72ec8f6a4705 (patch)
treec635d1f2989721a022eb1fa9e7677078c5b3cb29 /configure.ac
parentAdd experimental XI 2.1 multitouch support (diff)
downloadxf86-input-evdev-c9a2b4e9ce9b15e57241184df78c72ec8f6a4705.tar.gz
xf86-input-evdev-c9a2b4e9ce9b15e57241184df78c72ec8f6a4705.tar.bz2
xf86-input-evdev-c9a2b4e9ce9b15e57241184df78c72ec8f6a4705.zip
Use MTDev for multitouch devices
MTDev translates all multitouch devices to the slotted evdev protocol. This provides a clean and uniform interface and reduces message handling inside the input module and X. Signed-off-by: Chase Douglas <chase.douglas@canonical.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8acc862..cfff2d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,9 @@ AC_ARG_ENABLE(multitouch,
if test "x$MULTITOUCH" = xyes; then
AC_DEFINE(MULTITOUCH, 1, [Enable experimental multitouch code])
+
+ # Obtain compiler/linker options for mtdev
+ PKG_CHECK_MODULES(MTDEV, mtdev)
fi
# Define a configure option for an alternate input module directory