aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@redhat.com>2008-10-29 16:54:16 +1030
committerPeter Hutterer <peter.hutterer@redhat.com>2008-10-30 16:51:55 +1030
commitd5cf24d3f0075a467e026592bfbb76b207dea8eb (patch)
treef47fcb6e72a6d087b40731376835569a36dd02e0 /configure.ac
parentTreat BTN_[0-2] as LMR buttons if necessary. (diff)
downloadxf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.gz
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.bz2
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.zip
Add test/ directory for uinput-based test devices.
Three test devices provided: btn0 .... Provides BTN_0, BTN_1, BTN_2 instead of BTN_LEFT, BTN_MIDDLE, BTN_RIGHT. abs ..... Provdes x/y absolute axes, jumps between 100/100 and 120/120. absrel .. Provides relative x/y axes and absolute x/y axes at the same time. Signed-off-by: Peter Hutterer <peter.hutterer@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4233a22..4ba5a8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,21 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
+# Enable building everything in the test/ directory. These are uinput-based
+# devices that resemble random hardware that may or may not look like a mouse,
+# keyboard, etc.
+AC_ARG_ENABLE(testdevices,
+ AC_HELP_STRING([--enable-testdevices], [Build uinput-based test devices]),
+ [BUILD_TEST="yes"],
+ [BUILD_TEST="no"])
+AM_CONDITIONAL([BUILD_TEST], [test "x$BUILD_TEST" = "xyes"])
+
+if test "x$BUILD_TEST" = "xyes"; then
+ AC_CHECK_FUNC([dlopen], [],
+ AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
+ AC_SUBST([DLOPEN_LIBS])
+fi
+
# Checks for extensions
XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
@@ -75,4 +90,5 @@ AC_OUTPUT([Makefile
src/Makefile
man/Makefile
include/Makefile
+ test/Makefile
xorg-evdev.pc])