aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChase Douglas <chase.douglas@canonical.com>2010-11-08 11:08:01 -0500
committerPeter Hutterer <peter.hutterer@who-t.net>2011-11-11 15:50:06 +1000
commite18abd0049421a98e61c15c2d56cfe2821cf4739 (patch)
tree0ebde526d8b251044e3ecc06f3b6354056ad912c /configure.ac
parentUse a new "Virtual Device" boolean property to mark virtual devices (diff)
downloadxf86-input-evdev-e18abd0049421a98e61c15c2d56cfe2821cf4739.tar.gz
xf86-input-evdev-e18abd0049421a98e61c15c2d56cfe2821cf4739.tar.bz2
xf86-input-evdev-e18abd0049421a98e61c15c2d56cfe2821cf4739.zip
Add experimental XI 2.1 multitouch support
This multitouch addition only supports slotted MT evdev protocol devices. Support must be enabled at configure time using --enable-multitouch. Signed-off-by: Chase Douglas <chase.douglas@canonical.com> Amendments: XI_TouchMotion -> XI_TouchUpdate, rename mtMask to mt_mask Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aca3a41..8acc862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,17 @@ XORG_DEFAULT_OPTIONS
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.10] xproto inputproto)
PKG_CHECK_MODULES(UDEV, udev)
+# Whether to include support for experimental XI 2.2 multitouch
+AC_ARG_ENABLE(multitouch,
+ AC_HELP_STRING([--enable-multitouch],
+ [Enable experimental XI 2.2 multitouch support [[default: disabled]]]),
+ [MULTITOUCH=$enableval],
+ [MULTITOUCH=no])
+
+if test "x$MULTITOUCH" = xyes; then
+ AC_DEFINE(MULTITOUCH, 1, [Enable experimental multitouch code])
+fi
+
# Define a configure option for an alternate input module directory
AC_ARG_WITH(xorg-module-dir,
AC_HELP_STRING([--with-xorg-module-dir=DIR],