aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrej Gelenberg <andrej.gelenberg@udo.edu>2010-01-12 11:22:16 +0100
committerPeter Hutterer <peter.hutterer@who-t.net>2010-01-19 21:40:06 +1300
commite81cd935cfff18d3c387eed3e8083977c19c92f0 (patch)
tree6850583673cfde093045a4db101c127188c73539 /configure.ac
parentUpdate Sun license notices to current X.Org standard form (diff)
downloadxf86-input-evdev-e81cd935cfff18d3c387eed3e8083977c19c92f0.tar.gz
xf86-input-evdev-e81cd935cfff18d3c387eed3e8083977c19c92f0.tar.bz2
xf86-input-evdev-e81cd935cfff18d3c387eed3e8083977c19c92f0.zip
Implement XSetDeviceMode request handler
Implement XSetDeviceMode request handler for evdev. Devices with absolute axes can be switched in relative mode or absolute mode. Devices with relative axes can be switched only in relative mode. Other devices return BadMatch, cause they have no valuators and don't report motion events. New option "Mode" force devices with absolute axes to work in relative or absolute mode. Need xinputproto. Signed-off-by: Andrej Gelenberg <andrej.gelenberg@udo.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d8d0a7..759c1ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,9 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
+# Checks for extensions
+XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
+
# Checks for pkg-config packages. We need to be able to override sdkdir
# to satisfy silly distcheck requirements.
PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)