aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@redhat.com>2008-10-29 16:54:16 +1030
committerPeter Hutterer <peter.hutterer@redhat.com>2008-10-30 16:51:55 +1030
commitd5cf24d3f0075a467e026592bfbb76b207dea8eb (patch)
treef47fcb6e72a6d087b40731376835569a36dd02e0 /test/Makefile.am
parentTreat BTN_[0-2] as LMR buttons if necessary. (diff)
downloadxf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.gz
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.tar.bz2
xf86-input-evdev-d5cf24d3f0075a467e026592bfbb76b207dea8eb.zip
Add test/ directory for uinput-based test devices.
Three test devices provided: btn0 .... Provides BTN_0, BTN_1, BTN_2 instead of BTN_LEFT, BTN_MIDDLE, BTN_RIGHT. abs ..... Provdes x/y absolute axes, jumps between 100/100 and 120/120. absrel .. Provides relative x/y axes and absolute x/y axes at the same time. Signed-off-by: Peter Hutterer <peter.hutterer@redhat.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..4b417b8
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,35 @@
+# Copyright 2008 Red Hat, Inc.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+noinst_PROGRAMS=fakedev btn0 absrel abs
+
+fakedev_SOURCES=fakedev.c fakedev.h
+fakedev_LDFLAGS=$(DLOPEN_LIBS) -rdynamic
+
+LFLAGS=-shared -fPIC
+
+btn0_SOURCES=btn0.c
+btn0_LDFLAGS=$(LFLAGS)
+
+absrel_SOURCES=absrel.c
+absrel_LDFLAGS=$(LFLAGS)
+
+abs_SOURCES=abs.c
+abs_LDFLAGS=$(LFLAGS)