aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 2 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 46f3dc7..e53177e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,19 +44,11 @@ XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
# Obtain compiler/linker options from server and required extensions
-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.10] xproto inputproto)
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.12] xproto [inputproto >= 2.1.99.3])
PKG_CHECK_MODULES(UDEV, libudev)
-PKG_CHECK_MODULES(XI22, [inputproto >= 2.1.99.3] [xorg-server >= 1.11.99.901], HAVE_XI22="yes", HAVE_XI22="no")
PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
-
-if test "x$HAVE_XI22" = xyes; then
- # Obtain compiler/linker options for mtdev
- PKG_CHECK_MODULES(MTDEV, mtdev, HAVE_MTDEV="yes", HAVE_MTDEV="no")
-fi
-if test "x$HAVE_XI22" = xyes && test "x$HAVE_MTDEV" = xyes; then
- AC_DEFINE(MULTITOUCH, 1, [XI2.2 available])
-fi
+PKG_CHECK_MODULES(MTDEV, mtdev, HAVE_MTDEV="yes", HAVE_MTDEV="no")
# Define a configure option for an alternate input module directory
AC_ARG_WITH(xorg-module-dir,