aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1494a19..cfff2d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,21 @@ XORG_DEFAULT_OPTIONS
# Obtain compiler/linker options from server and required extensions
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.10] xproto inputproto)
+PKG_CHECK_MODULES(UDEV, udev)
+
+# Whether to include support for experimental XI 2.2 multitouch
+AC_ARG_ENABLE(multitouch,
+ AC_HELP_STRING([--enable-multitouch],
+ [Enable experimental XI 2.2 multitouch support [[default: disabled]]]),
+ [MULTITOUCH=$enableval],
+ [MULTITOUCH=no])
+
+if test "x$MULTITOUCH" = xyes; then
+ AC_DEFINE(MULTITOUCH, 1, [Enable experimental multitouch code])
+
+ # Obtain compiler/linker options for mtdev
+ PKG_CHECK_MODULES(MTDEV, mtdev)
+fi
# Define a configure option for an alternate input module directory
AC_ARG_WITH(xorg-module-dir,