aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac63
1 files changed, 30 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 2a6cf3b..da46c68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,33 +20,37 @@
#
# Process this file with autoconf to produce a configure script
-AC_PREREQ(2.57)
+# Initialize Autoconf
+AC_PREREQ([2.60])
AC_INIT([xf86-input-evdev],
- 2.4.0,
+ [2.4.0],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- xf86-input-evdev)
-
+ [xf86-input-evdev])
AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
AC_CONFIG_AUX_DIR(.)
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+# Initialize libtool
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
+# Initialize X.Org macros
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
+ [m4_fatal([must install xorg-macros 1.4 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.4)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER([config.h])
-
# Checks for programs.
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
-AC_PROG_CC
+AC_PROG_INSTALL
-AH_TOP([#include "xorg-server.h"])
+# Obtain compiler/linker options from server and required extensions
+PKG_CHECK_MODULES(XORG, xorg-server xproto inputproto)
+# Define a configure option for an alternate input module directory
AC_ARG_WITH(xorg-module-dir,
AC_HELP_STRING([--with-xorg-module-dir=DIR],
[Default xorg module directory [[default=$libdir/xorg/modules]]]),
@@ -55,28 +59,21 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
-# Checks for extensions
-XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
+# X Server SDK location is required to install evdev header files
+# This location is also relayed in the xorg-evdev.pc file
+sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
-# Checks for pkg-config packages. We need to be able to override sdkdir
-# to satisfy silly distcheck requirements.
-PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)
-
-AC_ARG_WITH([sdkdir], [],
- [sdkdir="$withval"],
- [sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`])
+# Workaround overriding sdkdir to be able to create a tarball when user has no
+# write permission in sdkdir. See DISTCHECK_CONFIGURE_FLAGS in Makefile.am
+AC_ARG_WITH([sdkdir], [], [sdkdir="$withval"])
AC_SUBST([sdkdir])
-# Checks for libraries.
-
-# Checks for header files.
-AC_HEADER_STDC
-
DRIVER_NAME=evdev
AC_SUBST([DRIVER_NAME])
-AC_OUTPUT([Makefile
- src/Makefile
- man/Makefile
- include/Makefile
- xorg-evdev.pc])
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ man/Makefile
+ include/Makefile
+ xorg-evdev.pc])
+AC_OUTPUT