summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2024-01-17 15:27:47 +0000
committerdakkar <dakkar@thenautilus.net>2024-01-17 15:27:47 +0000
commit24a7a70a6c85cc40c406a10b2268b00dc662d5d1 (patch)
tree0520cdcbf707bcb4938fa0cfa53d3e39b86da6ee
parentuntested meilisearch ebuild (diff)
downloadgentoo-overlay-24a7a70a6c85cc40c406a10b2268b00dc662d5d1.tar.gz
gentoo-overlay-24a7a70a6c85cc40c406a10b2268b00dc662d5d1.tar.bz2
gentoo-overlay-24a7a70a6c85cc40c406a10b2268b00dc662d5d1.zip
try git crates
still doesn't work
-rw-r--r--app-misc/meilisearch/meilisearch-1.6.0.ebuild36
1 files changed, 13 insertions, 23 deletions
diff --git a/app-misc/meilisearch/meilisearch-1.6.0.ebuild b/app-misc/meilisearch/meilisearch-1.6.0.ebuild
index 00bf029..6ddc7c7 100644
--- a/app-misc/meilisearch/meilisearch-1.6.0.ebuild
+++ b/app-misc/meilisearch/meilisearch-1.6.0.ebuild
@@ -1,5 +1,15 @@
EAPI=8
+declare -A GIT_CRATES=(
+ [actix-web-static-files]="https://github.com/kilork/actix-web-static-files.git;2d3b6160f0de4ba061c5d76b5704f34fb677f6df"
+ [candle-core]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
+ [candle-nn]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
+ [candle-transformers]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
+ [hf-hub]="https://github.com/dureuill/hf-hub.git;88d4f11cb9fa079f2912bacb96f5080b16825ce8"
+ [nelson]="https://github.com/meilisearch/nelson.git;675f13885548fb415ead8fbb447e9e6d9314000a"
+ [tokenizers]="https://github.com/huggingface/tokenizers.git;6357206cdcce4d78ffb1e0372feb456caea09375"
+)
+
CRATES="
actix-codec@0.5.1
actix-cors@0.7.0
@@ -13,7 +23,6 @@ CRATES="
actix-utils@3.0.1
actix-web@4.4.1
actix-web-codegen@4.2.0
- actix-web-static-files@3.0.5
addr2line@0.20.0
adler@1.0.2
aes@0.8.3
@@ -42,7 +51,6 @@ CRATES="
base64@0.13.1
base64@0.21.7
base64ct@1.6.0
- benchmarks@1.6.0
big_s@1.0.2
bimap@0.6.3
bincode@1.3.3
@@ -65,9 +73,6 @@ CRATES="
bzip2@0.4.4
bzip2-sys@0.1.11+1.0.8
calendrical_calculations@0.1.0
- candle-core@0.3.3
- candle-nn@0.3.3
- candle-transformers@0.3.3
cargo_toml@0.18.0
cast@0.3.0
cc@1.0.82
@@ -134,7 +139,6 @@ CRATES="
displaydoc@0.2.4
doc-comment@0.3.3
doxygen-rs@0.2.2
- dump@1.6.0
dyn-stack@0.10.0
either@1.9.0
embedded-io@0.4.0
@@ -159,12 +163,9 @@ CRATES="
fastrand@2.0.1
faux@0.1.10
faux_macros@0.1.10
- file-store@1.6.0
filetime@0.2.22
- filter-parser@1.6.0
fixed_decimal@0.5.4
flate2@1.0.28
- flatten-serde-json@1.6.0
fnv@1.0.7
form_urlencoded@1.2.1
fst@0.4.7
@@ -177,7 +178,6 @@ CRATES="
futures-sink@0.3.30
futures-task@0.3.30
futures-util@0.3.30
- fuzzers@1.6.0
fxhash@0.2.1
gemm@0.17.0
gemm-c32@0.17.0
@@ -207,7 +207,6 @@ CRATES="
heed-types@0.20.0-alpha.9
hermit-abi@0.3.2
hex@0.4.3
- hf-hub@0.3.2
hmac@0.12.1
http@0.2.11
http@1.0.0
@@ -258,7 +257,6 @@ CRATES="
ident_case@1.0.1
idna@0.5.0
impl-more@0.1.6
- index-scheduler@1.6.0
indexmap@1.9.3
indexmap@2.1.0
indicatif@0.17.7
@@ -275,7 +273,6 @@ CRATES="
jieba-rs@0.6.8
jobserver@0.1.26
js-sys@0.3.64
- json-depth-checker@1.6.0
jsonwebtoken@8.3.0
kstring@2.0.0
language-tags@0.3.2
@@ -320,15 +317,9 @@ CRATES="
manifest-dir-macros@0.1.18
maplit@1.0.2
md5@0.7.0
- meili-snap@1.6.0
- meilisearch@1.6.0
- meilisearch-auth@1.6.0
- meilisearch-types@1.6.0
- meilitool@1.6.0
memchr@2.7.1
memmap2@0.7.1
memmap2@0.9.3
- milli@1.6.0
mimalloc@0.1.39
mime@0.3.17
mime_guess@2.0.4
@@ -337,7 +328,6 @@ CRATES="
mio@0.8.9
monostate@0.1.9
monostate-impl@0.1.9
- nelson@0.1.0
nom@7.1.3
nom_locate@4.2.0
ntapi@0.4.1
@@ -366,7 +356,6 @@ CRATES="
pbkdf2@0.11.0
pem@1.1.1
percent-encoding@2.3.1
- permissive-json-pointer@1.6.0
pest@2.7.2
pest_derive@2.7.2
pest_generator@2.7.2
@@ -494,7 +483,6 @@ CRATES="
tinytemplate@1.2.1
tinyvec@1.6.0
tinyvec_macros@0.1.1
- tokenizers@0.14.1
tokio@1.35.1
tokio-macros@2.2.0
tokio-rustls@0.23.4
@@ -610,8 +598,10 @@ inherit cargo
DESCRIPTION="A lightning-fast search API"
HOMEPAGE="https://www.meilisearch.com"
+RESTRICT="mirror"
+
SRC_URI="https://github.com/meilisearch/meilisearch/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" $(cargo_crate_uris)"
+SRC_URI+=" ${CARGO_CRATE_URIS}"
SLOT="0"