summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGianni Ceccarelli <dakkar@thenautilus.net>2009-09-17 16:54:34 +0000
committerGianni Ceccarelli <dakkar@thenautilus.net>2009-09-17 16:54:34 +0000
commita80e656be637446872c9ccfe8ecc3335ca0cef18 (patch)
tree1ebaabf957ebb901f763fee7834ddc8aed9c9fdb
parentfix manifest (diff)
downloadgentoo-overlay-a80e656be637446872c9ccfe8ecc3335ca0cef18.tar.gz
gentoo-overlay-a80e656be637446872c9ccfe8ecc3335ca0cef18.tar.bz2
gentoo-overlay-a80e656be637446872c9ccfe8ecc3335ca0cef18.zip
new git version
I need it for the new cgit
-rw-r--r--dev-util/git/Manifest9
-rw-r--r--dev-util/git/files/50git-gentoo.el13
-rw-r--r--dev-util/git/files/git-daemon.confd19
-rw-r--r--dev-util/git/files/git-daemon.initd30
-rw-r--r--dev-util/git/files/git-daemon.xinetd13
-rw-r--r--dev-util/git/git-1.6.4.4.ebuild367
-rw-r--r--dev-util/git/metadata.xml26
7 files changed, 477 insertions, 0 deletions
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
new file mode 100644
index 0000000..89f8115
--- /dev/null
+++ b/dev-util/git/Manifest
@@ -0,0 +1,9 @@
+AUX 50git-gentoo.el 473 RMD160 3ae4696cc90d35bf2a1dca17cfe2fda78c0025e4 SHA1 7b67b759e6c3fc27552b211a6a48f3e4e2018c24 SHA256 c32f14d036e5ccb5c4583621dc10903346ab810ee838457e2de6e53d883348c0
+AUX git-daemon.confd 700 RMD160 2dea5af0c6b3aa5304aa5417bb40099bd4cdb45b SHA1 0b7c3078c4d284eb2572a5fb7c1efff5a4837f6e SHA256 9ca387e81ca875d4e543fa64398620451ff74273fa06b122a6af47db1fee1630
+AUX git-daemon.initd 741 RMD160 83ab8615b51c521ac0b961b42de7a7955f81147f SHA1 1dacace343cb952cab793cf46be110969473f84b SHA256 16a684cc66377e2840d09dd8cc39ed4cb13ce4807e22039f8bc176dff030ddec
+AUX git-daemon.xinetd 260 RMD160 5bfeca2541488bb955ca349474c1fa3e80913aef SHA1 88d6fc44644c88ed6f2ce54a936f41dc15d2268e SHA256 5025efbceed83835378cada3728448cbf445a1584e7cbd7736f568f4b6b52a67
+DIST git-1.6.4.4.tar.bz2 2174826 RMD160 8bad28bf8aedc6d5a9dcae39736c1ceeabbbe992 SHA1 da66a6323cc0842b19e3dbc5bb8ee5a59975037f SHA256 fc7e4d6c4172c62c93d5e974019f7193b03c8bc0a1c6f3a9fcc1d0928b808d7a
+DIST git-htmldocs-1.6.4.4.tar.bz2 756995 RMD160 a6d376213cfd442c046e8cce22c496e18c267ce9 SHA1 63a4e5d23f58bb76bba4630d176eca827f5273c0 SHA256 9adedf1d90fd2d9485a00d75c8c63bd6174c54faf1b99cedc5d8230a8f73d8c2
+DIST git-manpages-1.6.4.4.tar.bz2 248348 RMD160 fd1a267973373bc625336abe2b50545e12cc6fa4 SHA1 39b76f19751995ba3f093cac0b47900e22a5dbd2 SHA256 a2b2fb1aabdbb3e1e8ae9472523b9fef23c3e8a992bb8f68f17ad832a6e59c98
+EBUILD git-1.6.4.4.ebuild 9822 RMD160 54b6f4adad0b3bc0f51207750c733b92374672c4 SHA1 4b15d4ff175108396db5ba2d99db56cdaf031d09 SHA256 63a68c88629c1062e6572db4972f8f686762f09800a0c25939ab6fe12b716e7d
+MISC metadata.xml 1342 RMD160 ceb5a6a79f588f55f75bef5ac7ec905bd66ed992 SHA1 1184784e3c039539fb3fbcef1cf16ff778e583ab SHA256 b7eb9cdee9caae53f33273a9d6e9af47e9ba53483d8840d6f80f67b3cb90c92e
diff --git a/dev-util/git/files/50git-gentoo.el b/dev-util/git/files/50git-gentoo.el
new file mode 100644
index 0000000..42edd77
--- /dev/null
+++ b/dev-util/git/files/50git-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; dev-util/git site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'git-status "git" "Entry point into git-status mode." t)
+;;(autoload 'git-blame-mode "git-blame"
+;; "Minor mode for incremental blame for Git." t)
+
+;; GNU Emacs >=22.2 already includes vc-git.el.
+;; Enable the following only if Emacs has no GIT support.
+(unless (fboundp 'vc-git-registered)
+ (add-to-list 'load-path "@SITELISP@/compat")
+ (add-to-list 'vc-handled-backends 'GIT))
diff --git a/dev-util/git/files/git-daemon.confd b/dev-util/git/files/git-daemon.confd
new file mode 100644
index 0000000..75b4216
--- /dev/null
+++ b/dev-util/git/files/git-daemon.confd
@@ -0,0 +1,19 @@
+# conf.d file for git-daemon
+#
+# Please check man 1 git-daemon for more information about the options
+# git-daemon accepts. You MUST edit this to include your repositories you wish
+# to serve.
+#
+# Some of the meaningful options are:
+# --syslog --- Enables syslog logging
+# --verbose --- Enables verbose logging
+# --export-all --- Exports all repositories
+# --port=XXXX --- Starts in port XXXX instead of 9418
+#
+GITDAEMON_OPTS="--syslog /var/git"
+
+# To run an anonymous git safely, the following user should be able to only
+# read your Git repositories. It should not able able to write to anywhere on
+# your system, esp. not the repositories.
+GIT_USER="nobody"
+GIT_GROUP="nobody"
diff --git a/dev-util/git/files/git-daemon.initd b/dev-util/git/files/git-daemon.initd
new file mode 100644
index 0000000..726fca5
--- /dev/null
+++ b/dev-util/git/files/git-daemon.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/files/git-daemon.initd,v 1.6 2008/11/27 20:33:34 robbat2 Exp $
+
+PIDFILE=/var/run/git-daemon.pid
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ [ -e /lib/librc.so ] || BL1_COMPAT="--name git-daemon"
+ ebegin "Starting git-daemon"
+ start-stop-daemon --start --quiet --background \
+ --pidfile ${PIDFILE} ${BL1_COMPAT} \
+ --exec /usr/bin/git -- daemon \
+ --pid-file=${PIDFILE} \
+ --user=${GIT_USER} --group=${GIT_GROUP} \
+ ${GITDAEMON_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping git-daemon"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/dev-util/git/files/git-daemon.xinetd b/dev-util/git/files/git-daemon.xinetd
new file mode 100644
index 0000000..02c938d
--- /dev/null
+++ b/dev-util/git/files/git-daemon.xinetd
@@ -0,0 +1,13 @@
+service git-daemon
+{
+ disable = yes
+ socket_type = stream
+ wait = no
+ user = nobody
+ type = UNLISTED
+ protocol = tcp
+ log_on_failure += USERID
+ port = 9418
+ server = /usr/bin/git
+ server_args = daemon --inetd --syslog --export-all --base-path=/var/git
+}
diff --git a/dev-util/git/git-1.6.4.4.ebuild b/dev-util/git/git-1.6.4.4.ebuild
new file mode 100644
index 0000000..b3b3adb
--- /dev/null
+++ b/dev-util/git/git-1.6.4.4.ebuild
@@ -0,0 +1,367 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.4.3.ebuild,v 1.5 2009/09/16 03:42:14 robbat2 Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+[ "$PV" == "9999" ] && inherit git
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://www.git-scm.com/"
+if [ "$PV" != "9999" ]; then
+ SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+else
+ SRC_URI=""
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
+ # EGIT_REPO_URI="http://www.kernel.org/pub/scm/git/git.git"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="curl cgi doc emacs gtk iconv mozsha1 perl ppcsha1 tk threads webdav xinetd cvs subversion"
+
+# Common to both DEPEND and RDEPEND
+CDEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ app-arch/cpio
+ perl? ( dev-lang/perl )
+ tk? ( dev-lang/tk )
+ curl? (
+ net-misc/curl
+ webdav? ( dev-libs/expat )
+ )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${CDEPEND}
+ perl? ( dev-perl/Error
+ dev-perl/Net-SMTP-SSL
+ dev-perl/Authen-SASL
+ cgi? ( virtual/perl-CGI )
+ cvs? ( >=dev-util/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
+ subversion? ( dev-util/subversion[-dso] dev-perl/libwww-perl dev-perl/TermReadKey )
+ )
+ gtk?
+ (
+ >=dev-python/pygtk-2.8
+ || ( dev-python/pygtksourceview:2 dev-python/gtksourceview-python )
+ )"
+
+DEPEND="${CDEPEND}"
+
+# These are needed to build the docs
+if [ "$PV" == "9999" ]; then
+ DEPEND="${DEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ app-text/docbook2X
+ )"
+fi
+
+SITEFILE=50${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use perl ; then
+ use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
+ use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
+ use subversion && ewarn "git-svn needs USE=perl, it won't work"
+ fi
+ if use webdav && ! use curl ; then
+ ewarn "USE=webdav needs USE=curl. Ignoring"
+ fi
+ if use subversion && has_version dev-util/subversion && built_with_use --missing false dev-util/subversion dso ; then
+ ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
+ ewarn "with USE=dso, there may be weird crashes in git-svn. You"
+ ewarn "have been warned."
+ fi
+}
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ fi
+
+ use iconv \
+ || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk \
+ || myopts="${myopts} NO_TCLTK=YesPlease"
+ use perl \
+ && myopts="${myopts} INSTALLDIRS=vendor" \
+ || myopts="${myopts} NO_PERL=YesPlease"
+ use threads \
+ && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
+ use subversion \
+ || myopts="${myopts} NO_SVN_TESTS=YesPlease"
+
+ export MY_MAKEOPTS="${myopts}"
+}
+
+src_unpack() {
+ if [ "${PV}" != "9999" ]; then
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && \
+ cd "${S}"/Documentation && \
+ unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+ else
+ git_src_unpack
+ cd "${S}"
+ #cp "${FILESDIR}"/GIT-VERSION-GEN .
+ fi
+
+}
+
+src_prepare() {
+ # Noperl is being merged to upstream as of 2009/04/05
+ #epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
+
+ # GetOpt-Long v2.38 is strict
+ # Merged in 1.6.3 final 2009/05/07
+ #epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
+
+ sed -i \
+ -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
+ -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
+ -e 's:^\(CC = \).*$:\1$(OPTCC):' \
+ -e 's:^\(AR = \).*$:\1$(OPTAR):' \
+ Makefile || die "sed failed"
+
+ # Fix docbook2texi command
+ sed -i 's/DOCBOOK2X_TEXI=docbook2x-texi/DOCBOOK2X_TEXI=docbook2texi.pl/' \
+ Documentation/Makefile || die "sed failed"
+}
+
+git_emake() {
+ emake ${MY_MAKEOPTS} \
+ DESTDIR="${D}" \
+ OPTCFLAGS="${CFLAGS}" \
+ OPTLDFLAGS="${LDFLAGS}" \
+ OPTCC="$(tc-getCC)" \
+ OPTAR="$(tc-getAR)" \
+ prefix=/usr \
+ htmldir=/usr/share/doc/${PF}/html \
+ "$@"
+}
+
+src_configure() {
+ exportmakeopts
+}
+
+src_compile() {
+ git_emake || die "emake failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/git{,-blame}.el \
+ || die "emacs modules failed"
+ fi
+
+ if use perl && use cgi ; then
+ git_emake \
+ gitweb/gitweb.cgi \
+ || die "emake gitweb/gitweb.cgi failed"
+ fi
+
+ if [[ "$PV" == "9999" ]] && use doc; then
+ cd Documentation
+ git_emake man info html \
+ || die "emake man html info failed"
+ fi
+}
+
+src_install() {
+ git_emake \
+ install || \
+ die "make install failed"
+
+ doman man?/*.[157] Documentation/*.[157]
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/git.{el,elc} || die
+ elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
+ #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}${SITELISP}/${PN}/compat/.nosearch"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/fast-import/git-p4
+ dodoc contrib/fast-import/git-p4.txt
+ newbin contrib/fast-import/import-tars.perl import-tars
+
+ dodir /usr/share/${PN}/contrib
+ # The following are excluded:
+ # svnimport - use git-svn
+ # p4import - excluded because fast-import has a better one
+ # examples - these are stuff that is not used in Git anymore actually
+ # patches - stuff the Git guys made to go upstream to other places
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh stats \
+ workdir convert-objects blameview ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ if use perl && use cgi ; then
+ dodir /usr/share/${PN}/gitweb
+ insinto /usr/share/${PN}/gitweb
+ doins "${S}"/gitweb/gitweb.cgi
+ doins "${S}"/gitweb/gitweb.css
+ doins "${S}"/gitweb/git-{favicon,logo}.png
+
+ # Make sure it can run
+ fperms 0755 /usr/share/${PN}/gitweb/gitweb.cgi
+
+ # INSTALL discusses configuration issues, not just installation
+ docinto /
+ newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
+ newdoc "${S}"/gitweb/README README.gitweb
+
+ find "${D}"/usr/lib64/perl5/ \
+ -name .packlist \
+ -exec rm \{\} \;
+ fi
+ if ! use subversion ; then
+ rm -f "${D}"/usr/libexec/git-core/git-svn \
+ "${D}"/usr/share/man/man1/git-svn.1*
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+ fi
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ local disabled=""
+ local tests_cvs="t9200-git-cvsexportcommit.sh \
+ t9400-git-cvsserver-server.sh \
+ t9600-cvsimport.sh"
+ local tests_perl="t5502-quickfetch.sh \
+ t5512-ls-remote.sh \
+ t5520-pull.sh"
+
+ # Unzip is used only for the testcase code, not by any normal parts of Git.
+ if ! has_version app-arch/unzip ; then
+ einfo "Disabling tar-tree tests"
+ disabled="${disabled} t5000-tar-tree.sh"
+ fi
+
+ cvs=0
+ use cvs && let cvs=$cvs+1
+ if [[ ${EUID} -eq 0 ]]; then
+ if [[ $cvs -eq 1 ]]; then
+ ewarn "Skipping CVS tests because CVS does not work as root!"
+ ewarn "You should retest with FEATURES=userpriv!"
+ disabled="${disabled} ${tests_cvs}"
+ fi
+ # Bug #225601 - t0004 is not suitable for root perm
+ # Bug #219839 - t1004 is not suitable for root perm
+ disabled="${disabled} t0004-unwritable.sh t1004-read-tree-m-u-wf.sh"
+ else
+ [[ $cvs -gt 0 ]] && \
+ has_version dev-util/cvs && \
+ let cvs=$cvs+1
+ [[ $cvs -gt 0 ]] && \
+ built_with_use dev-util/cvs server && \
+ let cvs=$cvs+1
+ if [[ $cvs -lt 3 ]]; then
+ einfo "Disabling CVS tests (needs dev-util/cvs[USE=server])"
+ disabled="${disabled} ${tests_cvs}"
+ fi
+ fi
+
+ if ! use perl ; then
+ einfo "Disabling tests that need Perl"
+ disabled="${disabled} ${tests_perl}"
+ fi
+
+ # Reset all previously disabled tests
+ cd "${S}/t"
+ for i in *.sh.DISABLED ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
+ done
+ einfo "Disabled tests:"
+ for i in ${disabled} ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
+ done
+ cd "${S}"
+ # Now run the tests
+ einfo "Start test run"
+ git_emake \
+ test || die "tests failed"
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use subversion && has_version dev-util/subversion && ! built_with_use --missing false dev-util/subversion perl ; then
+ ewarn "You must build dev-util/subversion with USE=perl"
+ ewarn "to get the full functionality of git-svn!"
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache )"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/git/metadata.xml b/dev-util/git/metadata.xml
new file mode 100644
index 0000000..e870290
--- /dev/null
+++ b/dev-util/git/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Git - Fast Version Control System. Official titled
+ "GIT - the stupid content tracker".
+
+ Git is a popular version control system designed to handle very large
+ projects with speed and efficiency; it is used mainly for various open
+ source projects, most notably the Linux kernel.
+
+ Git falls in the category of distributed source code management tools,
+ similar to e.g. GNU Arch or Monotone (or BitKeeper in the proprietary
+ world). Every Git working directory is a full-fledged repository with full
+ revision tracking capabilities, not dependent on network access or a central
+ server.
+ </longdescription>
+ <use>
+ <flag name="cgi">Install gitweb too</flag>
+ <flag name="mozsha1">Makes git use an optimized SHA1 routine from Mozilla that should be fast on non-x86 machines.</flag>
+ <flag name="ppcsha1">Make use of a bundled routine that is optimized for the PPC arch.</flag>
+ <flag name="webdav">Adds support for push'ing to HTTP repositories via DAV.</flag>
+ <flag name="gtk">Include the gitview contrib tool.</flag>
+ <flag name="subversion">Include git-svn for <pkg>dev-util/subversion</pkg> support.</flag>
+ </use>
+</pkgmetadata>