summaryrefslogtreecommitdiff
path: root/app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2025-05-06 17:16:58 +0100
committerdakkar <dakkar@thenautilus.net>2025-05-06 17:16:58 +0100
commit1561e33011797500e1f3b0227f0a0048199df8bd (patch)
treed0a608d917c59b6397e03ea584b22f4364a7ae39 /app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild
parentfix msgpack option (diff)
downloadgentoo-overlay-master.tar.gz
gentoo-overlay-master.tar.bz2
gentoo-overlay-master.zip
bump smartctl_exporterHEADmaster
Diffstat (limited to 'app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild')
-rw-r--r--app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild b/app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild
new file mode 100644
index 0000000..30cbbe9
--- /dev/null
+++ b/app-metrics/smartctl_exporter/smartctl_exporter-0.14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Export smartctl statistics to prometheus"
+HOMEPAGE="https://github.com/prometheus-community/smartctl_exporter"
+
+SRC_URI="
+ ${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://www.thenautilus.net/gentoo-tarballs/${P}-vendor.tar.xz
+ "
+RESTRICT="mirror"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BDEPEND="dev-util/promu"
+DEPEND="dev-lang/go"
+RDEPEND="sys-apps/smartmontools"
+
+src_compile() {
+ emake build PROMU='/usr/bin/promu'
+}
+
+src_install() {
+ dodoc *.md
+ dobin ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}