summaryrefslogtreecommitdiff
path: root/app-misc/sparkleshare/sparkleshare-0.4.2.ebuild
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2011-12-02 18:07:43 +0000
committerdakkar <dakkar@thenautilus.net>2011-12-02 18:08:10 +0000
commitc2a8a6a2e4c4976fbe9805cdc853b4d808cba8c1 (patch)
treee3369512052ab358a6f62a4045cbd659531ea3b0 /app-misc/sparkleshare/sparkleshare-0.4.2.ebuild
parentmerge main portage changes to netqmail ebuild (diff)
downloadgentoo-overlay-c2a8a6a2e4c4976fbe9805cdc853b4d808cba8c1.tar.gz
gentoo-overlay-c2a8a6a2e4c4976fbe9805cdc853b4d808cba8c1.tar.bz2
gentoo-overlay-c2a8a6a2e4c4976fbe9805cdc853b4d808cba8c1.zip
SparkleShare ebuild
Diffstat (limited to 'app-misc/sparkleshare/sparkleshare-0.4.2.ebuild')
-rw-r--r--app-misc/sparkleshare/sparkleshare-0.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/sparkleshare/sparkleshare-0.4.2.ebuild b/app-misc/sparkleshare/sparkleshare-0.4.2.ebuild
new file mode 100644
index 0000000..fd34ba8
--- /dev/null
+++ b/app-misc/sparkleshare/sparkleshare-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# foo
+
+EAPI=3
+
+inherit base mono
+
+MY_PV="${PV/_beta/-beta}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SparkleShare is a file sharing and collaboration tool inspired by Dropbox"
+HOMEPAGE="http://www.sparkleshare.org"
+SRC_URI="https://github.com/downloads/hbons/SparkleShare/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/mono-2.2
+ >=dev-util/monodevelop-2.0
+ >=dev-dotnet/gtk-sharp-2.12.7
+ >=dev-dotnet/webkit-sharp-0.3
+ dev-dotnet/notify-sharp"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.7
+ net-misc/openssh
+ >=gnome-base/gvfs-1.3
+ dev-util/intltool"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable doc user-help) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README COPYING
+}
+