summaryrefslogtreecommitdiff
path: root/dev-libs/c-blosc
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2020-03-27 13:16:38 +0000
committerdakkar <dakkar@thenautilus.net>2020-03-27 14:55:24 +0000
commit0d41052d7eb2d7e45d839b5e042bfc5d796f9750 (patch)
tree4a714f232299a1bd31a57b01688d02254daf2a82 /dev-libs/c-blosc
parentand the manifest (diff)
downloadgentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.gz
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.bz2
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.zip
PrusaSlicer 2.2.0 and dependencies
there's apparently lots of new dependencies, or maybe newer versions are needed. I've added them to the PrusaSlicer ebuild, and added the ebuilds for them. Seems to work
Diffstat (limited to 'dev-libs/c-blosc')
-rw-r--r--dev-libs/c-blosc/Manifest3
-rw-r--r--dev-libs/c-blosc/c-blosc-1.17.1.ebuild51
-rw-r--r--dev-libs/c-blosc/metadata.xml18
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/Manifest b/dev-libs/c-blosc/Manifest
new file mode 100644
index 0000000..bebf2a7
--- /dev/null
+++ b/dev-libs/c-blosc/Manifest
@@ -0,0 +1,3 @@
+DIST c-blosc-1.17.1.tar.gz 880237 BLAKE2B 7084ce9d2b680c70f19eba1e52555539ee301afa1b05996b93f8e03abc1d395864cee4952739801276ab4bb8ba5c6607b2a5922856f509a0a60a3737d8c0da50 SHA512 926b15251b8537e5d1080b6488f357f05f948c193152d11f8e874834230459d4ac2514137f6cf2ef049f8625546e8687a85477594f523418398b62ca4271cb71
+EBUILD c-blosc-1.17.1.ebuild 1294 BLAKE2B 94ffc378f90e37dedc759f9bb0e6db47a544ae3f21b0691c10da34eebe532a68a5d4564039991bb97fadb7cb6180ec5a2962ce838180cfd5ef01c76ac69dc57d SHA512 767fec2d2b70efbff25ddabb3ed312694ed8e1f1c9ad6feb185a7391018d829e3984a433d23b8a562b0d43a82116fd85983fd48b6df6ba397830bc5f3752ca4e
+MISC metadata.xml 730 BLAKE2B 1e77a8bebe2f36cc0176d61bfb8839c80dc66b2c14fb0b8cdb2a997034308eae84ca6d9c403e4fc0da17b4ce1fcd571bcbf2f73d4349adc60a7e6163474df372 SHA512 eb015563106b9b23336c0954d6ab6395f823df52e33b64ce480376678d2d34ceb872775d607f97e8423ee888976f8bb74c6ee025a39b396882efec6af3af07f4
diff --git a/dev-libs/c-blosc/c-blosc-1.17.1.ebuild b/dev-libs/c-blosc/c-blosc-1.17.1.ebuild
new file mode 100644
index 0000000..6ae309c
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.17.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0/1"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="cpu_flags_x86_avx2 +lz4 +snappy static-libs test zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ lz4? ( >=app-arch/lz4-1.7.5:= )
+ snappy? ( app-arch/snappy )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md README_HEADER.rst README_THREADED.rst RELEASE_NOTES.rst THOUGHTS_FOR_2.0.txt ANNOUNCE.rst )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # remove bundled libs
+ rm -rf internal-complibs || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_BENCHMARKS=OFF
+ -DDEACTIVATE_AVX2=$(usex !cpu_flags_x86_avx2)
+ -DDEACTIVATE_LZ4=$(usex !lz4)
+ -DDEACTIVATE_SNAPPY=$(usex !snappy)
+ -DDEACTIVATE_ZLIB=$(usex !zlib)
+ -DDEACTIVATE_ZSTD=$(usex !zstd)
+ -DPREFER_EXTERNAL_LZ4=ON
+ -DPREFER_EXTERNAL_SNAPPY=ON
+ -DPREFER_EXTERNAL_ZLIB=ON
+ -DPREFER_EXTERNAL_ZSTD=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/metadata.xml b/dev-libs/c-blosc/metadata.xml
new file mode 100644
index 0000000..24926d9
--- /dev/null
+++ b/dev-libs/c-blosc/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Blosc is a compression library designed to transmit data to the
+ processor cache faster than the traditional non-compressed memory fetch.
+ Compression ratios are not very high, but the decompression is very
+ fast. Blosc is meant not only to reduce the size of large datasets on-disk
+ or in-memory, but also to accelerate memory-bound computations.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Blosc/c-blosc</remote-id>
+ </upstream>
+</pkgmetadata>