summaryrefslogtreecommitdiff
path: root/media-gfx
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2020-03-27 13:16:38 +0000
committerdakkar <dakkar@thenautilus.net>2020-03-27 14:55:24 +0000
commit0d41052d7eb2d7e45d839b5e042bfc5d796f9750 (patch)
tree4a714f232299a1bd31a57b01688d02254daf2a82 /media-gfx
parentand the manifest (diff)
downloadgentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.gz
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.bz2
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.zip
PrusaSlicer 2.2.0 and dependencies
there's apparently lots of new dependencies, or maybe newer versions are needed. I've added them to the PrusaSlicer ebuild, and added the ebuilds for them. Seems to work
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/PrusaSlicer/Manifest2
-rw-r--r--media-gfx/PrusaSlicer/PrusaSlicer-2.2.0.ebuild73
-rw-r--r--media-gfx/openvdb/Manifest3
-rw-r--r--media-gfx/openvdb/metadata.xml28
-rw-r--r--media-gfx/openvdb/openvdb-7.0.0.ebuild71
5 files changed, 177 insertions, 0 deletions
diff --git a/media-gfx/PrusaSlicer/Manifest b/media-gfx/PrusaSlicer/Manifest
index 0c5f4f1..7f0d8b2 100644
--- a/media-gfx/PrusaSlicer/Manifest
+++ b/media-gfx/PrusaSlicer/Manifest
@@ -1,2 +1,4 @@
DIST version_2.1.1.tar.gz 27551136 BLAKE2B 05948f7476cb41db83a4c70b6129df5b82c84d0e7de96c5d0a7dc0bad9442e4845a30e080f9ccd88caa09ec1f6c9daceb566a7cf8004e5d4d9a3f7026af1bc96 SHA512 30c00e6fc0dbd97ec2307d83a777f53039ed0eb8c4c26c9f4e581567025225ca1937032fe23fd09216d55b2703fa3c0d20a7f1efd713ba6c9ae5e32a6a088d6a
+DIST version_2.2.0.tar.gz 30811929 BLAKE2B cde004add53ee025728d566cb7331cb7b1eac5412e9ad3bee037d13277c24dcdc6024c91f09bb9ef0653a12a3ee7c5cb5cec21e2a00825d185472ea7036e08f5 SHA512 5c8dc5b581e04208a1ae53771ef2607da189ee85aadf501ce1480008f5a6ddb10bb528ddc2608d3f04acd26c583ff895ad4148d6a1397f002292e20098971e1d
EBUILD PrusaSlicer-2.1.1.ebuild 1466 BLAKE2B 9308684396460af7b574bd11006abe13d5530cf4388311146a2d03207adac0b8a0f610a4882f64f041b73f79d9a2a21032abe037fe8609a62ba3debbf42f4157 SHA512 c87108d6fef72d36faa19a35b377b73c2e7ddbda59927dacace1c19d9c1f1bd45a39ead286004267ea4e19e8cba206d5170ba7e16fb5784c256824c274a19df3
+EBUILD PrusaSlicer-2.2.0.ebuild 1611 BLAKE2B b3018c2335eb3f82b7d070048767a96a93d8b51bc2380ca94c2f58dfe1815540a88f5b8665f99affb775c2afc2d41eb841720b25e9dad9eeec6d8beedc39af84 SHA512 d60b8068cf79c0e7b4b1a48764409ceb23d30607c5f180da0e4d2ad3de74d20d78f8934f003d373a94d727c9c13f5682ca0873387e087354c221d734ea0e9b95
diff --git a/media-gfx/PrusaSlicer/PrusaSlicer-2.2.0.ebuild b/media-gfx/PrusaSlicer/PrusaSlicer-2.2.0.ebuild
new file mode 100644
index 0000000..5499f8e
--- /dev/null
+++ b/media-gfx/PrusaSlicer/PrusaSlicer-2.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# originally from https://bitbucket.org/szymonsz/gen2-overlay/src/master/media-gfx/PrusaSlicer/
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Prusa Edition of a mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
+HOMEPAGE="https://github.com/prusa3d/PrusaSlicer"
+SRC_URI="https://github.com/prusa3d/PrusaSlicer/archive/version_${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui test"
+
+# https://github.com/prusa3d/PrusaSlicer/issues/2150
+RDEPEND=">=dev-libs/boost-1.70[threads]
+ dev-libs/cereal
+ dev-cpp/tbb
+ sci-libs/nlopt[cxx]
+ net-misc/curl
+ dev-cpp/eigen
+ dev-libs/expat
+ media-libs/glew:0
+ >=media-libs/qhull-2019.1
+ >=dev-libs/c-blosc-1.17.0
+ >=media-libs/openexr-2.4.0
+ >=media-gfx/openvdb-6.2.1
+ >=sci-mathematics/cgal-5.0.0
+ gui? ( >=media-libs/freeglut-3
+ x11-libs/libXmu
+ x11-libs/wxGTK:3.0
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-cpp/gtest-1.7"
+
+S="${WORKDIR}/PrusaSlicer-version_${PV}"
+
+src_prepare() {
+ pushd "${WORKDIR}/PrusaSlicer-version_${PV}" || die
+ eapply_user
+ popd || die
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+
+ local mycmakeargs=(
+ -DSLIC3R_WX_STABLE=1
+ -DSLIC3R_FHS=1
+ -DSLIC3R_BUILD_ID=PrusaSlicer-${PV}
+ )
+
+ sed -i "s|\+UNKNOWN||g" version.inc
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ make_desktop_entry prusa-slicer \
+ "PrusaSlicer" \
+ "/usr/share/${PN}/icons/PrusaSlicer_128px.png" \
+ "Graphics;3DGraphics;Engineering;Development"
+}
diff --git a/media-gfx/openvdb/Manifest b/media-gfx/openvdb/Manifest
new file mode 100644
index 0000000..cd14b32
--- /dev/null
+++ b/media-gfx/openvdb/Manifest
@@ -0,0 +1,3 @@
+DIST openvdb-7.0.0.tar.gz 1872744 BLAKE2B e3a8c8d51f77e115d3d397abde0860a6322d56eb6c4795c1ba39539a23aab6cf37602ce7122965fbc3098b15b118b25010263f567e8003363b78c9b7d9d5dfd8 SHA512 f5321b22b10e192012d544cc02921d3d52f621778ec5aa21ba6d450f3e29f2fdbd76486ad390a0c008394dbc6ee4aeecc04527ef30e73adf71c1a08a021746b7
+EBUILD openvdb-7.0.0.ebuild 1666 BLAKE2B d74ba3bbaa405016bc2e7b8224e1c6495efd5d1e0562db5ebf071d6d2d41d2d220a1382d6d244d08294417aba55805c80af6df8393e4f8d5316b8f7e85afba88 SHA512 e18e3fd13624fde1515fd8df52f8eed219777542dabf282154c8ff4857721d39787b30e650ee4330caf45dc4145401a04cf84c13e500bb25941e24a77344255d
+MISC metadata.xml 1033 BLAKE2B 303f49be8253322a0bbb94875f7b9b03e127e9d2ab2eea64fbac1cd51f50d5be749c4c45c9491fbf3f56de7420fdb47913b6ef3c2d12f5ea0545042f68d990d4 SHA512 a81a1cd4684197d1d9455b1398c9ba1592d596d52c8e8fc5c0cc8de0357c1f1df7478fd76e4e42cda09524b0bbf41985e13cf530adb7ca7f1605f086207301a8
diff --git a/media-gfx/openvdb/metadata.xml b/media-gfx/openvdb/metadata.xml
new file mode 100644
index 0000000..7470615
--- /dev/null
+++ b/media-gfx/openvdb/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>agrigo2001@yahoo.com.au</email>
+ <name>Adrian Grigo</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Libraries from Dreamworks Animation for the efficient manipulation
+ of volumetric data used in big budget movies like 'Cloudy with a
+ Chance of Meatballs2' and 'How to Train Your Dragon 2'.
+ </longdescription>
+ <use>
+ <flag restrict="&lt;media-gfx/openvdb-5.0.0" name="abi3-compat">
+ Disables newer features to maintain compatibility with ABI3. Enabled by default.
+ </flag>
+ <flag restrict="&gt;=media-gfx/openvdb-5.0.0" name="abi4-compat">
+ Disables newer features to maintain compatibility with ABI4. Enabled by default.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">dreamworksanimation/openvdb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/openvdb/openvdb-7.0.0.ebuild b/media-gfx/openvdb/openvdb-7.0.0.ebuild
new file mode 100644
index 0000000..c7f8dd8
--- /dev/null
+++ b/media-gfx/openvdb/openvdb-7.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit cmake-utils flag-o-matic python-single-r1
+
+DESCRIPTION="Libs for the efficient manipulation of volumetric data"
+HOMEPAGE="https://www.openvdb.org"
+SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62:=
+ >=dev-libs/c-blosc-1.5.0
+ dev-libs/jemalloc
+ dev-libs/log4cplus
+ media-libs/glfw:=
+ media-libs/openexr:=
+ sys-libs/zlib:=
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.62:=[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+DEPEND="${RDEPEND}
+ dev-cpp/tbb
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ test? ( dev-util/cppunit )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_NO_SYSTEM_FROM_IMPORTED=true
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DOPENVDB_BUILD_DOCS=$(usex doc)
+ -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
+ -DOPENVDB_BUILD_UNITTESTS=$(usex test)
+ -DOPENVDB_ENABLE_RPATH=OFF
+ )
+
+ use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
+
+ cmake-utils_src_configure
+}