summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2020-03-27 13:16:38 +0000
committerdakkar <dakkar@thenautilus.net>2020-03-27 14:55:24 +0000
commit0d41052d7eb2d7e45d839b5e042bfc5d796f9750 (patch)
tree4a714f232299a1bd31a57b01688d02254daf2a82 /media-libs
parentand the manifest (diff)
downloadgentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.gz
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.bz2
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.zip
PrusaSlicer 2.2.0 and dependencies
there's apparently lots of new dependencies, or maybe newer versions are needed. I've added them to the PrusaSlicer ebuild, and added the ebuilds for them. Seems to work
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr/Manifest3
-rw-r--r--media-libs/openexr/metadata.xml10
-rw-r--r--media-libs/openexr/openexr-2.4.1.ebuild29
-rw-r--r--media-libs/qhull/Manifest3
-rw-r--r--media-libs/qhull/metadata.xml20
-rw-r--r--media-libs/qhull/qhull-2019.1.ebuild35
6 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
new file mode 100644
index 0000000..7f6cf1c
--- /dev/null
+++ b/media-libs/openexr/Manifest
@@ -0,0 +1,3 @@
+DIST v2.4.1.tar.gz 26809861 BLAKE2B e43b064c82e8b0fb0ad1c4fa82160fc2d3739c42d4e317d9b02b43ce05f7f4576cc7aae9274e6b59303fc58c75c32bf74a7007c86cbbdd608b9b951576e36d66 SHA512 23c0c07fafa42f832e67cbfeeeb12b6b9e373dd0a5b858f463bf5c4d0661c58fad662cef64ef6a3053f0db2f69aee46816568b814872d617284664d1effbbbab
+EBUILD openexr-2.4.1.ebuild 699 BLAKE2B 65360b9ba066b8c292558ef065df31edeb67451e1de5bdb35d84454f38cf9beb32fc5aa437bd7b9f533c35dec86b5e6ee2dfd005fedee52a0d5b07b81e11d44e SHA512 79f0efadc34b9907025701a39406f80428b97f6fbd2e280ee8a811f3ecf1b30b828bff01288d8f91bd16b462bdc42decdad0fcee45b892a6e2e864e4d78a3686
+MISC metadata.xml 303 BLAKE2B 53fb5019bd6fe939d485f1eccb4a140ca9b7ce121b06744d8155842ccb6c5e1378ea39a9ae74c8d519be7b3926bd76040df4b8107137fcc2e25be97431e7a1be SHA512 0ab8d735dd7a8e0dc96b14cfde1ae06969d15cfbad956f4fda60b093660aee38fe98709376eedc9362a26858678d2f28eec795c1accb2560858fd804a11bb7ca
diff --git a/media-libs/openexr/metadata.xml b/media-libs/openexr/metadata.xml
new file mode 100644
index 0000000..fc9e500
--- /dev/null
+++ b/media-libs/openexr/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openexr/openexr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/openexr/openexr-2.4.1.ebuild b/media-libs/openexr/openexr-2.4.1.ebuild
new file mode 100644
index 0000000..c16fbcc
--- /dev/null
+++ b/media-libs/openexr/openexr-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/openexr/openexr/archive/v${PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 -arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="sys-libs/zlib
+ !media-libs/ilmbase"
+
+RESTRICT="test" # Tests broken upstream doesn't really care about them, bug #656680
+
+DOCS=( CHANGES.md README.md )
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/media-libs/qhull/Manifest b/media-libs/qhull/Manifest
new file mode 100644
index 0000000..5844cb0
--- /dev/null
+++ b/media-libs/qhull/Manifest
@@ -0,0 +1,3 @@
+DIST qhull-2019.1.tar.gz 1236686 BLAKE2B 546f9a8784275239fbe94d1cc3c3f7ede8e4435c05221f9931fbe7bc085c20a306c335b8882deaa03292b49511726a417d75c86f14f7646693eb36bb93e03d30 SHA512 efcaf2af45f3c401f5f677cac8e3ffc056f870bf62f852982ca880282c428920fad13071017b8d8b7b6fc416380c6f3fe6973aa0b37a2322c234774325b14f1c
+EBUILD qhull-2019.1.ebuild 885 BLAKE2B e10b834d33075d5c31849d442fe80f5d245580cd7d4fc90a03956b0c1b181743cbb168602152ff28cc8143121403d812a5111491df62542bd232d7b7791b7cdd SHA512 253940dd62c99a0ac2e6449c514657e9bb1a0fe573c26be1bb267b261dcfff7cd4f93f63b987382e3b42f29ce2042a10f3280944cb7a469fe31f7d3c6cc9ea93
+MISC metadata.xml 977 BLAKE2B 57a86855387223c875830b8d60eb02f89f469dc4949f094255f43e0251cb537049d0a99a0eb9500c639730f6a0db518ec2b3a4ae050e3c9ea2f508cdbe790e98 SHA512 6e676d2faff561e67e077869a61747c834131ea67acb098497153c98d3bca38032ffa2ab57d6b612cfa4f1fbdb8b05b0c9a9132ab0cdeae5579bdac236b9a1f2
diff --git a/media-libs/qhull/metadata.xml b/media-libs/qhull/metadata.xml
new file mode 100644
index 0000000..c6a6929
--- /dev/null
+++ b/media-libs/qhull/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Qhull computes the convex hull, Delaunay triangulation, Voronoi
+ diagram, halfspace intersection about a point, furthest-site
+ Delaunay triangulation, and furthest-site Voronoi diagram. The
+ source code runs in 2-d, 3-d, 4-d, and higher dimensions. Qhull
+ implements the Quickhull algorithm for computing the convex hull. It
+ handles roundoff errors from floating point arithmetic. It computes
+ volumes, surface areas, and approximations to the convex hull.
+ Qhull does not support constrained Delaunay triangulations,
+ triangulation of non-convex surfaces, mesh generation of non-convex
+ objects, or medium-sized inputs in 9-D and higher.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/qhull/qhull-2019.1.ebuild b/media-libs/qhull/qhull-2019.1.ebuild
new file mode 100644
index 0000000..57c7763
--- /dev/null
+++ b/media-libs/qhull/qhull-2019.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="http://www.qhull.org/download/${PN}-2019-src-7.3.2.tgz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ mycmakeargs+=(
+ -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
+ -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${P}/html
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # compatibility with previous installs
+ dosym libqhull /usr/include/qhull
+ if ! use doc; then
+ rm -rf "${ED}"/usr/share/doc/${P}/html || die
+ fi
+}