summaryrefslogtreecommitdiff
path: root/net-libs/webkit-gtk/files
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2018-01-29 06:36:15 +0000
committerdakkar <dakkar@thenautilus.net>2018-01-29 06:36:15 +0000
commit604261627ef2ac502b5da70bc5db32af5c3e6bf2 (patch)
treeec4f7fb84a14afd1760fc60a49c0c34010fde8f1 /net-libs/webkit-gtk/files
parentlet's keep using old webkit for claws (diff)
downloadgentoo-overlay-604261627ef2ac502b5da70bc5db32af5c3e6bf2.tar.gz
gentoo-overlay-604261627ef2ac502b5da70bc5db32af5c3e6bf2.tar.bz2
gentoo-overlay-604261627ef2ac502b5da70bc5db32af5c3e6bf2.zip
add webkit files
Diffstat (limited to 'net-libs/webkit-gtk/files')
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch10
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch67
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.2.5-hppa-platform.patch20
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.2.5-ia64-platform.patch12
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.1-ia64-malloc.patch20
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.11-video-web-audio.patch11
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.4-atomic-ppc.patch32
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.4-jpeg-9a.patch30
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.7-disable-webgl.patch11
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch29
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.8.5-fix-ia64-build.patch21
11 files changed, 263 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch
new file mode 100644
index 0000000..c94f545
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac.old 2013-03-02 09:22:53.791750644 +0200
++++ b/configure.ac 2013-03-02 09:24:56.725213764 +0200
+@@ -24,6 +24,7 @@
+ m4_include([Source/autotools/SetupLibtool.m4])
+ m4_include([Source/autotools/ReadCommandLineArguments.m4])
+ m4_include([Source/autotools/FindDependencies.m4])
++GTK_DOC_CHECK([1.10])
+ m4_include([Source/autotools/SetupCompilerFlags.m4])
+ m4_include([Source/autotools/SetupAutoconfHeader.m4])
+
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
new file mode 100644
index 0000000..5ad357e
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
@@ -0,0 +1,67 @@
+Original from:
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-gtkxtbin.c.diff?format=txt
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-PluginViewGtk.cpp.diff?format=txt
+
+Adapted for 1.6.1
+
+--- Source/WebCore/plugins/gtk/PluginViewGtk.cpp
++++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp
+@@ -70,6 +70,8 @@
+ #endif
+ #include <gtk/gtk.h>
+
++#undef XP_UNIX
++
+ #if defined(XP_UNIX)
+ #include "RefPtrCairo.h"
+ #include "gtk2xtbin.h"
+@@ -439,9 +441,9 @@
+ event->setDefaultHandled();
+ }
+
+-#if defined(XP_UNIX)
+ void PluginView::handleFocusInEvent()
+ {
++#if defined(XP_UNIX)
+ if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
+ return;
+
+@@ -454,10 +456,12 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
++#endif
+ }
+
+ void PluginView::handleFocusOutEvent()
+ {
++#if defined(XP_UNIX)
+ if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
+ return;
+
+@@ -470,8 +474,8 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
+-}
+ #endif
++}
+
+ void PluginView::setParent(ScrollView* parent)
+ {
+--- Source/WebCore/plugins/gtk/gtk2xtbin.c
++++ Source/WebCore/plugins/gtk/gtk2xtbin.c
+@@ -41,7 +41,7 @@
+ * The GtkXtBin widget allows for Xt toolkit code to be used
+ * inside a GTK application.
+ */
+-
++#if 0
+ #include "GtkVersioning.h"
+ #include "xembed.h"
+ #include "gtk2xtbin.h"
+@@ -966,3 +966,4 @@
+
+ return;
+ }
++#endif
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-hppa-platform.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-hppa-platform.patch
new file mode 100644
index 0000000..8aee778
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-hppa-platform.patch
@@ -0,0 +1,20 @@
+Index: webkitgtk/Source/WTF/wtf/Platform.h
+===================================================================
+--- webkitgtk.orig/Source/WTF/wtf/Platform.h
++++ webkitgtk/Source/WTF/wtf/Platform.h
+@@ -72,6 +72,15 @@
+ #define WTF_CPU_BIG_ENDIAN 1
+ #endif
+
++/* CPU(HPPA) - HP PARISC */
++#if defined(__hppa__)
++#define WTF_CPU_HPPA 1
++#define WTF_CPU_BIG_ENDIAN 1
++#define ENABLE_JIT 0
++#define ENABLE_YARR_JIT 0
++#define ENABLE_ASSEMBLER 0
++#endif
++
+ /* CPU(IA64) - Itanium / IA-64 */
+ #if defined(__ia64__)
+ #define WTF_CPU_IA64 1
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-ia64-platform.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-ia64-platform.patch
new file mode 100644
index 0000000..a63e9e8
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-ia64-platform.patch
@@ -0,0 +1,12 @@
+--- a/Source/WTF/wtf/Platform.h 2014-02-25 00:33:16.561606810 +0100
++++ b/Source/WTF/wtf/Platform.h 2014-02-25 00:49:52.895512955 +0100
+@@ -79,6 +79,9 @@
+ #if !defined(__LP64__)
+ #define WTF_CPU_IA64_32 1
+ #endif
++#define ENABLE_JIT 0
++#define ENABLE_YARR_JIT 0
++#define ENABLE_ASSEMBLER 0
+ #endif
+
+ /* CPU(MIPS) - MIPS 32-bit */
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.1-ia64-malloc.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.1-ia64-malloc.patch
new file mode 100644
index 0000000..8c387ff
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.1-ia64-malloc.patch
@@ -0,0 +1,20 @@
+Description: Fix wide pointer issues on ia64 (closes: #642750).
+Author: Stephan Schreiber <info@fs-driver.org>
+Index: webkitgtk/Source/WTF/wtf/Platform.h
+===================================================================
+--- webkitgtk.orig/Source/WTF/wtf/Platform.h
++++ webkitgtk/Source/WTF/wtf/Platform.h
+@@ -705,6 +705,13 @@
+ #define ENABLE_JIT 1
+ #endif
+
++/* FIXME: The fast malloc implementation is broken on Itanium / IA64 because
++ some memory barriers are missing in the thread-unsafe code around the
++ pagemap_cache_ object. */
++#if CPU(IA64) || CPU(IA64_32)
++#define USE_SYSTEM_MALLOC 1
++#endif
++
+ /* The JIT is enabled by default on all x86, x86-64, ARM & MIPS platforms except Win64. */
+ #if !defined(ENABLE_JIT) \
+ && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)) \
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.11-video-web-audio.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.11-video-web-audio.patch
new file mode 100644
index 0000000..ead696c
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.11-video-web-audio.patch
@@ -0,0 +1,11 @@
+diff -purN a/Source/WebCore/platform/gtk/RenderThemeGtk2.cpp b/Source/WebCore/platform/gtk/RenderThemeGtk2.cpp
+--- a/Source/WebCore/platform/gtk/RenderThemeGtk2.cpp 2016-03-14 08:09:01.000000000 +0100
++++ b/Source/WebCore/platform/gtk/RenderThemeGtk2.cpp 2016-04-10 19:43:00.215345381 +0200
+@@ -40,6 +40,7 @@
+ #include "PaintInfo.h"
+ #include "PlatformContextCairo.h"
+ #include "RenderElement.h"
++#include "RenderBox.h"
+ #include "TextDirection.h"
+ #include "UserAgentStyleSheets.h"
+ #include "WidgetRenderingContext.h"
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-atomic-ppc.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-atomic-ppc.patch
new file mode 100644
index 0000000..c160376
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-atomic-ppc.patch
@@ -0,0 +1,32 @@
+$OpenBSD: patch-Source_WebKit2_Platform_IPC_Connection_h,v 1.2 2014/07/14 21:13:31 ajacoutot Exp $
+https://bugs.webkit.org/show_bug.cgi?id=130837
+--- a/Source/WebKit2/Platform/IPC/Connection.h.orig Fri Jul 4 11:06:55 2014
++++ b/Source/WebKit2/Platform/IPC/Connection.h Mon Jul 14 19:31:35 2014
+@@ -216,7 +216,11 @@ class Connection : public ThreadSafeRefCounted<Connect
+
+ Client* m_client;
+ bool m_isServer;
++#if CPU(PPC)
++ uint64_t m_syncRequestID;
++#else
+ std::atomic<uint64_t> m_syncRequestID;
++#endif
+
+ bool m_onlySendMessagesAsDispatchWhenWaitingForSyncReplyWhenProcessingSuchAMessage;
+ bool m_shouldExitOnSyncMessageSendFailure;
+$OpenBSD: patch-Source_WebKit2_UIProcess_StatisticsRequest_cpp,v 1.3 2014/03/27 22:03:48 landry Exp $
+https://bugs.webkit.org/show_bug.cgi?id=130837
+--- a/Source/WebKit2/UIProcess/StatisticsRequest.cpp.orig Thu Mar 27 21:13:49 2014
++++ b/Source/WebKit2/UIProcess/StatisticsRequest.cpp Thu Mar 27 21:14:23 2014
+@@ -44,7 +44,11 @@ StatisticsRequest::~StatisticsRequest()
+
+ uint64_t StatisticsRequest::addOutstandingRequest()
+ {
++#if CPU(PPC)
++ static int64_t uniqueRequestID;
++#else
+ static std::atomic<int64_t> uniqueRequestID;
++#endif
+
+ uint64_t requestID = ++uniqueRequestID;
+ m_outstandingRequests.add(requestID);
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-jpeg-9a.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-jpeg-9a.patch
new file mode 100644
index 0000000..cded605
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.4-jpeg-9a.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/481688
+http://trac.webkit.org/changeset/166490/trunk/Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp
+
+--- a/Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp
++++ b/Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp
+@@ -334,5 +334,5 @@
+ case JPEG_HEADER:
+ // Read file parameters with jpeg_read_header().
+- if (jpeg_read_header(&m_info, true) == JPEG_SUSPENDED)
++ if (jpeg_read_header(&m_info, TRUE) == JPEG_SUSPENDED)
+ return false; // I/O suspension.
+
+@@ -420,7 +420,7 @@
+ m_info.dct_method = dctMethod();
+ m_info.dither_mode = ditherMode();
+- m_info.do_fancy_upsampling = doFancyUpsampling();
+- m_info.enable_2pass_quant = false;
+- m_info.do_block_smoothing = true;
++ m_info.do_fancy_upsampling = doFancyUpsampling() ? TRUE : FALSE;
++ m_info.enable_2pass_quant = FALSE;
++ m_info.do_block_smoothing = TRUE;
+
+ // Start decompressor.
+@@ -573,5 +573,5 @@
+ // called, then we have hit the end of the buffer. A return value of false
+ // indicates that we have no data to supply yet.
+- return false;
++ return FALSE;
+ }
+
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.7-disable-webgl.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.7-disable-webgl.patch
new file mode 100644
index 0000000..67760e2
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.7-disable-webgl.patch
@@ -0,0 +1,11 @@
+--- webkitgtk-2.4.6.orig/Source/WebCore/platform/graphics/OpenGLShims.cpp 2014-09-26 11:40:44.000000000 +0400
++++ webkitgtk-2.4.6.orig/Source/WebCore/platform/graphics/OpenGLShims.cpp 2014-10-13 15:38:38.496444600 +0400
+@@ -17,7 +17,7 @@
+ */
+
+ #include "config.h"
+-#if USE(3D_GRAPHICS) || defined(QT_OPENGL_SHIMS)
++#if USE(3D_GRAPHICS) || defined(QT_OPENGL_SHIMS) || USE(EGL) || USE(GLX)
+
+ #define DISABLE_SHIMS
+ #include "OpenGLShims.h"
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch
new file mode 100644
index 0000000..bd8507c
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch
@@ -0,0 +1,29 @@
+Fedora patch fixes build failure for gcc-6 (abs/fabs ambifuity)
+https://bugs.webkit.org/show_bug.cgi?id=159124#c1
+https://bugs.gentoo.org/show_bug.cgi?id=592048
+diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp
+--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2015-05-20 03:03:24.000000000 -0600
++++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2016-02-07 11:30:42.392686308 -0700
+@@ -85,8 +85,8 @@
+ guint32 eventTime = getEventTime(event);
+
+ if ((event->type == GDK_2BUTTON_PRESS || event->type == GDK_3BUTTON_PRESS)
+- || ((abs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
+- && (abs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
++ || ((fabs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
++ && (fabs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
+ && (eventTime - m_previousClickTime < static_cast<guint>(doubleClickTime))
+ && (buttonEvent->button == m_previousClickButton)))
+ m_currentClickCount++;
+diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp
+--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2015-05-20 03:03:24.000000000 -0600
++++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2016-02-07 11:49:36.384691005 -0700
+@@ -659,7 +659,7 @@
+ if (!std::isfinite(time))
+ return String::fromUTF8(_("indefinite time"));
+
+- int seconds = static_cast<int>(abs(time));
++ int seconds = static_cast<int>(fabs(time));
+ int days = seconds / (60 * 60 * 24);
+ int hours = seconds / (60 * 60);
+ int minutes = (seconds / 60) % 60;
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-fix-ia64-build.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-fix-ia64-build.patch
new file mode 100644
index 0000000..6c88c49
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-fix-ia64-build.patch
@@ -0,0 +1,21 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -98,6 +98,8 @@
+ set(WTF_CPU_PPC64LE 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "parisc*")
+ set(WTF_CPU_HPPA 1)
++elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "ia64")
++ set(WTF_CPU_IA64 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "s390")
+ set(WTF_CPU_S390 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "s390x")
+--- a/Source/JavaScriptCore/CMakeLists.txt
++++ b/Source/JavaScriptCore/CMakeLists.txt
+@@ -1147,6 +1147,7 @@
+ endif ()
+ elseif (WTF_CPU_ARM64)
+ elseif (WTF_CPU_HPPA)
++elseif (WTF_CPU_IA64)
+ elseif (WTF_CPU_PPC)
+ elseif (WTF_CPU_PPC64)
+ elseif (WTF_CPU_PPC64LE)