summaryrefslogtreecommitdiff
path: root/sci-mathematics/cgal/cgal-5.0.2.ebuild
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2020-03-27 13:16:38 +0000
committerdakkar <dakkar@thenautilus.net>2020-03-27 14:55:24 +0000
commit0d41052d7eb2d7e45d839b5e042bfc5d796f9750 (patch)
tree4a714f232299a1bd31a57b01688d02254daf2a82 /sci-mathematics/cgal/cgal-5.0.2.ebuild
parentand the manifest (diff)
downloadgentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.gz
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.tar.bz2
gentoo-overlay-0d41052d7eb2d7e45d839b5e042bfc5d796f9750.zip
PrusaSlicer 2.2.0 and dependencies
there's apparently lots of new dependencies, or maybe newer versions are needed. I've added them to the PrusaSlicer ebuild, and added the ebuilds for them. Seems to work
Diffstat (limited to 'sci-mathematics/cgal/cgal-5.0.2.ebuild')
-rw-r--r--sci-mathematics/cgal/cgal-5.0.2.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/cgal-5.0.2.ebuild b/sci-mathematics/cgal/cgal-5.0.2.ebuild
new file mode 100644
index 0000000..b4978c6
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-5.0.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+MY_P=CGAL-${PV}
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="https://www.cgal.org/"
+SRC_URI="
+ https://github.com/CGAL/cgal/releases/download/releases%2F${MY_P}/${MY_P}.tar.xz
+ doc? ( https://github.com/CGAL/cgal/releases/download/releases%2F${MY_P}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0/13"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi ntl qt5"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/boost:=[threads]
+ dev-libs/mpfr:0=
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ virtual/glu:=
+ virtual/opengl:=
+ gmp? ( dev-libs/gmp:=[cxx] )
+ mpfi? ( sci-libs/mpfi )
+ ntl? ( dev-libs/ntl )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.11.1-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # modules provided by dev-util/cmake and dev-cpp/eigen
+ rm cmake/modules/FindEigen3.cmake || die
+ sed -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR="$(get_libdir)"
+ -DCGAL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/CGAL"
+ -DWITH_LEDA=OFF
+ -DWITH_Eigen3=ON
+ -DWITH_ZLIB=ON
+ -DWITH_GMP="$(usex gmp)"
+ -DWITH_GMPXX="$(usex gmp)"
+ -DWITH_MPFI="$(usex mpfi)"
+ -DWITH_NTL="$(usex ntl)"
+ -DWITH_CGAL_Qt5="$(usex qt5)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ dodoc -r examples demo
+ docompress -x /usr/share/doc/${PF}/{examples,demo}
+ fi
+}