summaryrefslogtreecommitdiff
path: root/sci-misc/opencsg/opencsg-1.3.1.ebuild
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2010-10-01 14:17:09 +0100
committerdakkar <dakkar@thenautilus.net>2010-10-01 14:17:09 +0100
commit457dac8491049d82e6146fcd661a1a07033ff92a (patch)
treebc7c56d051cad48eccaaa34588a9a2338a1a2ee5 /sci-misc/opencsg/opencsg-1.3.1.ebuild
parentcleanup (diff)
downloadgentoo-overlay-457dac8491049d82e6146fcd661a1a07033ff92a.tar.gz
gentoo-overlay-457dac8491049d82e6146fcd661a1a07033ff92a.tar.bz2
gentoo-overlay-457dac8491049d82e6146fcd661a1a07033ff92a.zip
openscad & opencsg
Diffstat (limited to 'sci-misc/opencsg/opencsg-1.3.1.ebuild')
-rw-r--r--sci-misc/opencsg/opencsg-1.3.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-misc/opencsg/opencsg-1.3.1.ebuild b/sci-misc/opencsg/opencsg-1.3.1.ebuild
new file mode 100644
index 0000000..085c6e8
--- /dev/null
+++ b/sci-misc/opencsg/opencsg-1.3.1.ebuild
@@ -0,0 +1,41 @@
+#
+
+EAPI="2"
+
+inherit qt4-r2
+
+DESCRIPTION="The Constructive Solid Geometry rendering library"
+HOMEPAGE="http://www.opencsg.org/"
+SRC_URI="http://www.opencsg.org/OpenCSG-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="media-libs/glew"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/OpenCSG-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ #Use System glew
+ rm -Rf ${S}/glew
+}
+
+src_prepare() {
+ # We actually want to install somthing
+ cat << EOF >> src/src.pro
+include.path=/usr/include
+include.files=../include/*
+target.path=/usr/lib
+INSTALLS += target include
+EOF
+
+}
+
+src_configure() {
+ eqmake4 "${S}"/src/src.pro
+}