summaryrefslogtreecommitdiff
path: root/app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild')
-rw-r--r--app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild b/app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild
new file mode 100644
index 0000000..398b3b6
--- /dev/null
+++ b/app-metrics/smartctl_exporter/smartctl_exporter-0.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Export smartctl statistics to prometheus"
+HOMEPAGE="https://github.com/prometheus-community/smartctl_exporter"
+
+SRC_URI="
+ ${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://www.thenautilus.net/gentoo-tarballs/smartctl_exporter-0.13.0-vendor.tar.xz
+ "
+RESTRICT="mirror"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BDEPEND="dev-util/promu"
+DEPEND="dev-lang/go"
+RDEPEND="sys-apps/smartmontools"
+
+src_compile() {
+ emake build PROMU='/usr/bin/promu'
+}
+
+src_install() {
+ dodoc *.md
+ dobin ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}