summaryrefslogtreecommitdiff
path: root/app-misc/meilisearch/meilisearch-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/meilisearch/meilisearch-1.6.0.ebuild')
-rw-r--r--app-misc/meilisearch/meilisearch-1.6.0.ebuild246
1 files changed, 124 insertions, 122 deletions
diff --git a/app-misc/meilisearch/meilisearch-1.6.0.ebuild b/app-misc/meilisearch/meilisearch-1.6.0.ebuild
index 6ddc7c7..3db0289 100644
--- a/app-misc/meilisearch/meilisearch-1.6.0.ebuild
+++ b/app-misc/meilisearch/meilisearch-1.6.0.ebuild
@@ -1,27 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
EAPI=8
declare -A GIT_CRATES=(
- [actix-web-static-files]="https://github.com/kilork/actix-web-static-files.git;2d3b6160f0de4ba061c5d76b5704f34fb677f6df"
- [candle-core]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
- [candle-nn]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
- [candle-transformers]="https://github.com/huggingface/candle.git;5270224f407502b82fe90bc2622894ce3871b002"
- [hf-hub]="https://github.com/dureuill/hf-hub.git;88d4f11cb9fa079f2912bacb96f5080b16825ce8"
- [nelson]="https://github.com/meilisearch/nelson.git;675f13885548fb415ead8fbb447e9e6d9314000a"
- [tokenizers]="https://github.com/huggingface/tokenizers.git;6357206cdcce4d78ffb1e0372feb456caea09375"
+ [actix-web-static-files]="https://github.com/kilork/actix-web-static-files;2d3b6160f0de4ba061c5d76b5704f34fb677f6df"
+ [arroy]="https://github.com/meilisearch/arroy;d372648212e561a4845077cdb9239423d78655a2"
+ [candle-core]="https://github.com/huggingface/candle;f4fcf6090045ac44122fd5f0a7e46db6e3e16528;candle-%commit%/candle-core"
+ [candle-nn]="https://github.com/huggingface/candle;f4fcf6090045ac44122fd5f0a7e46db6e3e16528;candle-%commit%/candle-nn"
+ [candle-transformers]="https://github.com/huggingface/candle;f4fcf6090045ac44122fd5f0a7e46db6e3e16528;candle-%commit%/candle-transformers"
+ [hf-hub]="https://github.com/dureuill/hf-hub;88d4f11cb9fa079f2912bacb96f5080b16825ce8"
+ [nelson]="https://github.com/meilisearch/nelson;675f13885548fb415ead8fbb447e9e6d9314000a"
+ [tokenizers]="https://github.com/huggingface/tokenizers;6357206cdcce4d78ffb1e0372feb456caea09375;tokenizers-%commit%/tokenizers"
)
CRATES="
actix-codec@0.5.1
- actix-cors@0.7.0
- actix-http@3.5.1
+ actix-cors@0.6.4
+ actix-http@3.3.1
actix-macros@0.2.4
actix-router@0.5.1
- actix-rt@2.9.0
+ actix-rt@2.8.0
actix-server@2.2.0
actix-service@2.0.2
- actix-tls@3.1.1
+ actix-tls@3.0.3
actix-utils@3.0.1
- actix-web@4.4.1
+ actix-web@4.3.1
actix-web-codegen@4.2.0
addr2line@0.20.0
adler@1.0.2
@@ -32,24 +36,23 @@ CRATES="
alloc-no-stdlib@2.0.4
alloc-stdlib@0.2.2
anes@0.1.6
- anstream@0.6.7
+ anstream@0.6.4
anstyle@1.0.1
anstyle-parse@0.2.1
anstyle-query@1.0.0
anstyle-wincon@3.0.1
- anyhow@1.0.79
+ anyhow@1.0.75
anymap2@0.13.0
- arbitrary@1.3.2
- arroy@0.2.0
+ arbitrary@1.3.0
assert-json-diff@2.0.2
async-stream@0.3.5
async-stream-impl@0.3.5
- async-trait@0.1.77
+ async-trait@0.1.72
atomic-polyfill@0.1.11
autocfg@1.1.0
backtrace@0.3.68
base64@0.13.1
- base64@0.21.7
+ base64@0.21.5
base64ct@1.6.0
big_s@1.0.2
bimap@0.6.3
@@ -59,21 +62,21 @@ CRATES="
bitflags@1.3.2
bitflags@2.4.1
block-buffer@0.10.4
- brotli@3.4.0
- brotli-decompressor@2.5.1
- bstr@1.9.0
+ brotli@3.3.4
+ brotli-decompressor@2.3.4
+ bstr@1.8.0
bumpalo@3.13.0
byte-unit@4.0.19
bytecount@0.6.3
bytemuck@1.14.0
bytemuck_derive@1.4.1
byteorder@1.5.0
- bytes@1.5.0
+ bytes@1.4.0
bytestring@1.3.0
bzip2@0.4.4
bzip2-sys@0.1.11+1.0.8
calendrical_calculations@0.1.0
- cargo_toml@0.18.0
+ cargo_toml@0.15.3
cast@0.3.0
cc@1.0.82
cedarwood@0.4.6
@@ -84,8 +87,8 @@ CRATES="
ciborium-io@0.2.1
ciborium-ll@0.2.1
cipher@0.4.4
- clap@4.4.17
- clap_builder@4.4.17
+ clap@4.4.8
+ clap_builder@4.4.8
clap_derive@4.4.7
clap_lex@0.6.0
cobs@0.2.3
@@ -94,6 +97,7 @@ CRATES="
console@0.15.7
constant_time_eq@0.1.5
convert_case@0.4.0
+ convert_case@0.5.0
convert_case@0.6.0
cookie@0.16.2
core-foundation@0.9.3
@@ -105,31 +109,28 @@ CRATES="
criterion@0.5.1
criterion-plot@0.5.0
critical-section@1.1.1
- crossbeam@0.8.4
- crossbeam-channel@0.5.11
- crossbeam-deque@0.8.5
- crossbeam-epoch@0.9.18
- crossbeam-queue@0.3.11
- crossbeam-utils@0.8.19
+ crossbeam@0.8.2
+ crossbeam-channel@0.5.8
+ crossbeam-deque@0.8.3
+ crossbeam-epoch@0.9.15
+ crossbeam-queue@0.3.8
+ crossbeam-utils@0.8.16
crunchy@0.2.2
crypto-common@0.1.6
- csv@1.3.0
- csv-core@0.1.11
+ csv@1.2.2
+ csv-core@0.1.10
darling@0.14.4
- darling@0.20.3
darling_core@0.14.4
- darling_core@0.20.3
darling_macro@0.14.4
- darling_macro@0.20.3
deduplicating_array@0.1.5
deranged@0.3.9
- derive_arbitrary@1.3.2
+ derive_arbitrary@1.3.1
derive_builder@0.12.0
derive_builder_core@0.12.0
derive_builder_macro@0.12.0
derive_more@0.99.17
- deserr@0.6.1
- deserr-internal@0.7.0
+ deserr@0.6.0
+ deserr-internal@0.6.0
deunicode@1.3.3
digest@0.10.7
dirs@5.0.1
@@ -152,40 +153,39 @@ CRATES="
encoding_index_tests@0.1.4
encoding_rs@0.8.32
encoding_rs_io@0.1.7
- enum-as-inner@0.6.0
- enum-iterator@1.5.0
- enum-iterator-derive@1.3.0
- env_logger@0.10.1
+ enum-iterator@1.4.1
+ enum-iterator-derive@1.2.1
+ env_logger@0.10.0
equivalent@1.0.1
errno@0.3.8
esaxx-rs@0.1.10
- fancy-regex@0.12.0
- fastrand@2.0.1
- faux@0.1.10
- faux_macros@0.1.10
+ fancy-regex@0.11.0
+ fastrand@2.0.0
+ faux@0.1.9
+ faux_macros@0.1.9
filetime@0.2.22
fixed_decimal@0.5.4
flate2@1.0.28
fnv@1.0.7
form_urlencoded@1.2.1
fst@0.4.7
- futures@0.3.30
- futures-channel@0.3.30
- futures-core@0.3.30
- futures-executor@0.3.30
- futures-io@0.3.30
- futures-macro@0.3.30
- futures-sink@0.3.30
- futures-task@0.3.30
- futures-util@0.3.30
+ futures@0.3.29
+ futures-channel@0.3.29
+ futures-core@0.3.29
+ futures-executor@0.3.29
+ futures-io@0.3.29
+ futures-macro@0.3.29
+ futures-sink@0.3.29
+ futures-task@0.3.29
+ futures-util@0.3.29
fxhash@0.2.1
- gemm@0.17.0
- gemm-c32@0.17.0
- gemm-c64@0.17.0
- gemm-common@0.17.0
- gemm-f16@0.17.0
- gemm-f32@0.17.0
- gemm-f64@0.17.0
+ gemm@0.16.15
+ gemm-c32@0.16.15
+ gemm-c64@0.16.15
+ gemm-common@0.16.15
+ gemm-f16@0.16.15
+ gemm-f32@0.16.15
+ gemm-f64@0.16.15
generic-array@0.14.7
geoutils@0.5.1
getrandom@0.2.10
@@ -199,7 +199,7 @@ CRATES="
half@2.3.1
hash32@0.2.1
hashbrown@0.12.3
- hashbrown@0.14.3
+ hashbrown@0.14.0
heapless@0.7.16
heck@0.4.1
heed@0.20.0-alpha.9
@@ -208,7 +208,7 @@ CRATES="
hermit-abi@0.3.2
hex@0.4.3
hmac@0.12.1
- http@0.2.11
+ http@0.2.9
http@1.0.0
http-body@0.4.5
httparse@1.8.0
@@ -256,17 +256,16 @@ CRATES="
icu_unicodeset_parse@0.1.1
ident_case@1.0.1
idna@0.5.0
- impl-more@0.1.6
indexmap@1.9.3
- indexmap@2.1.0
+ indexmap@2.0.0
indicatif@0.17.7
inout@0.1.3
- insta@1.34.0
+ insta@1.31.0
instant@0.1.12
io-lifetimes@1.0.11
ipnet@2.8.0
irg-kvariants@0.1.0
- is-terminal@0.4.10
+ is-terminal@0.4.9
itertools@0.10.5
itertools@0.11.0
itoa@1.0.9
@@ -281,7 +280,7 @@ CRATES="
libc@0.2.150
libgit2-sys@0.14.2+1.5.1
libm@0.2.7
- libmimalloc-sys@0.1.35
+ libmimalloc-sys@0.1.33
libz-sys@1.1.12
lindera-cc-cedict-builder@0.27.1
lindera-compress@0.27.1
@@ -314,13 +313,14 @@ CRATES="
lz4_flex@0.10.0
macro_rules_attribute@0.2.0
macro_rules_attribute-proc_macro@0.2.0
- manifest-dir-macros@0.1.18
+ manifest-dir-macros@0.1.17
maplit@1.0.2
md5@0.7.0
- memchr@2.7.1
+ memchr@2.6.4
memmap2@0.7.1
- memmap2@0.9.3
- mimalloc@0.1.39
+ memmap2@0.9.0
+ memoffset@0.9.0
+ mimalloc@0.1.37
mime@0.3.17
mime_guess@2.0.4
minimal-lexical@0.2.1
@@ -329,7 +329,7 @@ CRATES="
monostate@0.1.9
monostate-impl@0.1.9
nom@7.1.3
- nom_locate@4.2.0
+ nom_locate@4.1.0
ntapi@0.4.1
num-bigint@0.4.3
num-complex@0.4.4
@@ -339,11 +339,12 @@ CRATES="
number_prefix@0.4.0
object@0.31.1
obkv@0.2.1
- once_cell@1.19.0
+ once_cell@1.18.0
onig@6.4.0
onig_sys@69.8.1
oorandom@11.1.3
option-ext@0.2.0
+ ordered-float@3.7.0
ordered-float@4.2.0
page_size@0.5.0
page_size@0.6.0
@@ -365,7 +366,7 @@ CRATES="
phf_generator@0.11.2
phf_macros@0.11.2
phf_shared@0.11.2
- pin-project-lite@0.2.13
+ pin-project-lite@0.2.11
pin-utils@0.1.0
pinyin@0.9.0
pkg-config@0.3.27
@@ -379,13 +380,13 @@ CRATES="
ppv-lite86@0.2.17
proc-macro-error@1.0.4
proc-macro-error-attr@1.0.4
- proc-macro2@1.0.76
+ proc-macro2@1.0.66
procfs@0.14.2
prometheus@0.13.3
protobuf@2.28.0
puffin@0.16.0
pulp@0.18.4
- quote@1.0.35
+ quote@1.0.32
rand@0.8.5
rand_chacha@0.3.1
rand_core@0.6.4
@@ -400,16 +401,15 @@ CRATES="
redox_syscall@0.3.5
redox_syscall@0.4.1
redox_users@0.4.3
- regex@1.10.2
+ regex@1.9.3
regex-automata@0.2.0
+ regex-automata@0.3.6
regex-automata@0.4.3
regex-syntax@0.7.4
- regex-syntax@0.8.2
- reqwest@0.11.23
+ reqwest@0.11.22
retain_mut@0.1.7
riff@1.0.1
ring@0.16.20
- ring@0.17.3
roaring@0.10.2
rstar@0.11.0
rustc-demangle@0.1.23
@@ -417,38 +417,37 @@ CRATES="
rustc_version@0.4.0
rustix@0.36.16
rustix@0.38.26
- rustls@0.20.9
+ rustls@0.20.8
rustls@0.21.6
- rustls-pemfile@1.0.4
- rustls-webpki@0.101.7
+ rustls-pemfile@1.0.3
+ rustls-webpki@0.101.3
rustversion@1.0.14
ryu@1.0.15
- safetensors@0.4.1
+ safetensors@0.3.3
same-file@1.0.6
scopeguard@1.2.0
sct@0.7.0
- segment@0.2.3
+ segment@0.2.2
semver@1.0.18
seq-macro@0.3.5
- serde@1.0.195
+ serde@1.0.190
serde-cs@0.2.4
- serde_derive@1.0.195
- serde_json@1.0.111
+ serde_derive@1.0.190
+ serde_json@1.0.104
serde_plain@1.0.2
- serde_spanned@0.6.5
+ serde_spanned@0.6.3
serde_urlencoded@0.7.1
sha-1@0.10.1
sha1@0.10.5
- sha2@0.10.8
+ sha2@0.10.7
signal-hook-registry@1.4.1
similar@2.2.1
simple_asn1@0.6.2
- siphasher@0.3.11
- siphasher@1.0.0
+ siphasher@0.3.10
slab@0.4.8
slice-group-by@0.3.1
smallstr@0.3.0
- smallvec@1.12.0
+ smallvec@1.11.0
smartstring@1.0.1
socket2@0.4.9
socket2@0.5.5
@@ -462,36 +461,35 @@ CRATES="
strsim@0.10.0
subtle@2.5.0
syn@1.0.109
- syn@2.0.48
+ syn@2.0.28
synchronoise@1.0.1
synstructure@0.13.0
- sysctl@0.5.5
- sysinfo@0.30.5
+ sysinfo@0.29.7
system-configuration@0.5.1
system-configuration-sys@0.5.0
tar@0.4.40
- temp-env@0.3.6
- tempfile@3.9.0
- termcolor@1.4.1
- thiserror@1.0.56
- thiserror-impl@1.0.56
- tiktoken-rs@0.5.8
- time@0.3.31
+ temp-env@0.3.4
+ tempfile@3.8.1
+ termcolor@1.2.0
+ thiserror@1.0.50
+ thiserror-impl@1.0.50
+ tiktoken-rs@0.5.7
+ time@0.3.30
time-core@0.1.2
- time-macros@0.2.16
+ time-macros@0.2.15
tinystr@0.7.4
tinytemplate@1.2.1
tinyvec@1.6.0
tinyvec_macros@0.1.1
- tokio@1.35.1
+ tokio@1.34.0
tokio-macros@2.2.0
tokio-rustls@0.23.4
tokio-rustls@0.24.1
tokio-stream@0.1.14
tokio-util@0.7.8
- toml@0.8.8
- toml_datetime@0.6.5
- toml_edit@0.21.0
+ toml@0.7.6
+ toml_datetime@0.6.3
+ toml_edit@0.19.14
tower-service@0.3.2
tracing@0.1.37
tracing-attributes@0.1.27
@@ -499,7 +497,7 @@ CRATES="
try-lock@0.2.4
typenum@1.16.0
ucd-trie@0.1.6
- unescaper@0.1.3
+ unescaper@0.1.2
unicase@2.6.0
unicode-bidi@0.3.13
unicode-ident@1.0.11
@@ -510,7 +508,6 @@ CRATES="
unicode-xid@0.2.4
unicode_categories@0.1.1
untrusted@0.7.1
- untrusted@0.9.0
ureq@2.9.1
url@2.5.0
urlencoding@2.1.3
@@ -518,11 +515,12 @@ CRATES="
utf8-width@0.1.6
utf8_iter@1.0.3
utf8parse@0.2.1
- uuid@1.6.1
+ uuid@0.8.2
+ uuid@1.5.0
vcpkg@0.2.15
vergen@7.5.1
version_check@0.9.4
- walkdir@2.4.0
+ walkdir@2.3.3
wana_kana@3.0.0
want@0.3.1
wasi@0.11.0+wasi-snapshot-preview1
@@ -542,8 +540,6 @@ CRATES="
winapi-i686-pc-windows-gnu@0.4.0
winapi-util@0.1.5
winapi-x86_64-pc-windows-gnu@0.4.0
- windows@0.52.0
- windows-core@0.52.0
windows-sys@0.45.0
windows-sys@0.48.0
windows-sys@0.52.0
@@ -597,13 +593,19 @@ inherit cargo
DESCRIPTION="A lightning-fast search API"
HOMEPAGE="https://www.meilisearch.com"
-
-RESTRICT="mirror"
-
SRC_URI="https://github.com/meilisearch/meilisearch/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" ${CARGO_CRATE_URIS}"
-SLOT="0"
+RESTRICT="mirror"
-LICENSE="MIT"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 GPL-3 ISC LGPL-2 LGPL-3 MIT MPL-2.0 MPL-2.0+ Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/${PN}"