summaryrefslogtreecommitdiff
path: root/games-misc
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/ponysay/Manifest4
-rw-r--r--games-misc/ponysay/files/ponysay-py38.patch33
-rw-r--r--games-misc/ponysay/metadata.xml15
-rw-r--r--games-misc/ponysay/ponysay-3.0.3-r1.ebuild64
4 files changed, 116 insertions, 0 deletions
diff --git a/games-misc/ponysay/Manifest b/games-misc/ponysay/Manifest
new file mode 100644
index 0000000..3595d6c
--- /dev/null
+++ b/games-misc/ponysay/Manifest
@@ -0,0 +1,4 @@
+AUX ponysay-py38.patch 1252 BLAKE2B e75b01218d665afcfe37e7911b5badef9dd02b8f1415a3035dad46bc4166e3d6aeb5ece02586b2f29567f8ba236e792979c11486d2dd11184fb7fb3e01999d81 SHA512 6a8ef5dee268468392b9ac0d74b5c8f90b2ecd85238f5517c7d29c60358a0dc81be4cfcb775ddc94c737739ff657371664524a859de790f0302e5638cef8a9d5
+DIST ponysay-3.0.3.tar.gz 2139074 BLAKE2B 3ba477268d68ff9a92bad8028d0b960a2a6152057146368723fea432100a71517c0c343d34b2b1c580fcfa1945bdc273fed276cf4a10c702514e6699cda87a2c SHA512 d6ff905404192bdc207952a4a914458d7f25ddcfcea95763ae277a2a3bc7ab33e86a0a229c1b10ff7295b7a89d6e1b61406feefb6bdf9026f4076d0ed70dbe93
+EBUILD ponysay-3.0.3-r1.ebuild 1501 BLAKE2B 74bd700c0f3e6ea2d5d923ad053bb68724b74e06865c7f5fa94c599971ba1a54591d99f1f66885521062c3714735d83ebc2bad11722d1e9aee2883b5239c6916 SHA512 74d4f5f12bbadadbc9733bf21bf35d5ea005e866127317d8fd178f919a3e48c47427287d9abcdebf2c840f8a678caa3591780b6fb274bfc6102828c6cce21124
+MISC metadata.xml 500 BLAKE2B a937b3dcb9fb8a11ceefa20731973096578f503d711731a22afd3fbaea75b25d37cb736af36fbe8696a0d01afca261a4156444ac6b26b9a87f30f29d785f7408 SHA512 612eee4d25e1f3e3ef18b08ac4fcf59fbee5ab179d1f4da5e6784909c1985aa816317eba1a4c1a0aae8b1dfc0bfcc63ea44ab844b1400e565a2ebfaf5d7f8d4c
diff --git a/games-misc/ponysay/files/ponysay-py38.patch b/games-misc/ponysay/files/ponysay-py38.patch
new file mode 100644
index 0000000..6f9fee1
--- /dev/null
+++ b/games-misc/ponysay/files/ponysay-py38.patch
@@ -0,0 +1,33 @@
+From 69c23e3ae1e1e9e9f1ee3a06a706d755a4b1de48 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C3=93ZES=20=C3=81d=C3=A1m=20Istv=C3=A1n?=
+ <mozes.adam.istvan@pm.me>
+Date: Sat, 16 Nov 2019 09:58:28 +0100
+Subject: [PATCH] fix: do not compare literal with "is not"
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Python3.8 issued the following warning on each ponysay invocation:
+
+/bin/ponysay/backend.py:294: SyntaxWarning: "is not" with a literal. Did you mean "!="?
+
+This has been corrected here.
+
+Signed-off-by: MÓZES Ádám István <mozes.adam.istvan@pm.me>
+---
+ src/backend.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/backend.py b/src/backend.py
+index 2cc539a5..82ff1496 100644
+--- a/src/backend.py
++++ b/src/backend.py
+@@ -291,7 +291,7 @@ def __processPony(self):
+ props = dollar[7:]
+ if len(props) > 0:
+ if ',' in props:
+- if props[0] is not ',':
++ if props[0] != ',':
+ w = props[:props.index(',')]
+ h = int(props[props.index(',') + 1:])
+ else:
diff --git a/games-misc/ponysay/metadata.xml b/games-misc/ponysay/metadata.xml
new file mode 100644
index 0000000..288c0bc
--- /dev/null
+++ b/games-misc/ponysay/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="non-free">Install non-free ponies (i.e. from the MLP franchise)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">erkin/ponysay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/ponysay/ponysay-3.0.3-r1.ebuild b/games-misc/ponysay/ponysay-3.0.3-r1.ebuild
new file mode 100644
index 0000000..4f1ca71
--- /dev/null
+++ b/games-misc/ponysay/ponysay-3.0.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="cowsay reimplemention for ponies"
+HOMEPAGE="https://github.com/erkin/ponysay"
+SRC_URI="https://github.com/erkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +non-free bash-completion fish-completion zsh-completion"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}/ponysay-py38.patch"
+)
+
+BDEPEND="${PYTHON_DEPS}
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${PYTHON_DEPS}
+ fish-completion? ( app-shells/fish )
+ zsh-completion? ( app-shells/zsh )"
+
+setup_py() {
+ "${PYTHON}" setup.py \
+ --prefix="${EPREFIX}"/usr \
+ --everything \
+ --without-info-compression \
+ --without-man-compression \
+ --without-pdf-compression \
+ --without-shared-cache \
+ --freedom=$(usex non-free no yes) \
+ $(use_with fish-completion) \
+ $(use_with zsh-completion) \
+ $(use_with doc info) \
+ $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
+ "${@}" || die
+}
+
+src_compile() {
+ setup_py \
+ $(use_with bash-completion) \
+ build
+}
+
+src_install() {
+ setup_py \
+ --without-bash-completion \
+ --destdir="${D}" \
+ prebuilt
+
+ python_fix_shebang "${ED}"/usr/bin/${PN}
+
+ rm -rv "${ED}"/usr/share/licenses || die
+ dodoc CHANGELOG CONTRIBUTING CREDITS README.md
+
+ use bash-completion &&
+ newbashcomp completion/bash-completion.${PN}.install ${PN}
+}