summaryrefslogtreecommitdiff
path: root/mail-mta/netqmail/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/netqmail/files')
-rw-r--r--mail-mta/netqmail/files/1.06-fbsd-utmpx.patch64
-rw-r--r--mail-mta/netqmail/files/conf-common11
-rw-r--r--mail-mta/netqmail/files/conf-qmqpd5
-rw-r--r--mail-mta/netqmail/files/conf-qmtpd5
-rw-r--r--mail-mta/netqmail/files/conf-smtpd5
-rw-r--r--mail-mta/netqmail/files/genqmail-20080406-ldflags.patch13
-rw-r--r--mail-mta/netqmail/files/servercert.cnf4
7 files changed, 88 insertions, 19 deletions
diff --git a/mail-mta/netqmail/files/1.06-fbsd-utmpx.patch b/mail-mta/netqmail/files/1.06-fbsd-utmpx.patch
new file mode 100644
index 0000000..8500eb5
--- /dev/null
+++ b/mail-mta/netqmail/files/1.06-fbsd-utmpx.patch
@@ -0,0 +1,64 @@
+--- qbiff.c.orig 2010-04-06 08:43:28.000000000 -0300
++++ qbiff.c 2010-04-06 08:44:35.000000000 -0300
+@@ -1,13 +1,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <utmp.h>
+-#ifndef UTMP_FILE
+-#ifdef _PATH_UTMP
+-#define UTMP_FILE _PATH_UTMP
+-#else
+-#define UTMP_FILE "/etc/utmp"
+-#endif
+-#endif
++#include <utmpx.h>
+ #include "readwrite.h"
+ #include "stralloc.h"
+ #include "substdio.h"
+@@ -21,15 +14,12 @@
+ #include "env.h"
+ #include "exit.h"
+
+-substdio ssutmp;
+-char bufutmp[sizeof(struct utmp) * 16];
+-int fdutmp;
+ substdio sstty;
+ char buftty[1024];
+ int fdtty;
+
+-struct utmp ut;
+-char line[sizeof(ut.ut_line) + 1];
++struct utmpx *ut;
++char line[sizeof(ut->ut_line) + 1];
+ stralloc woof = {0};
+ stralloc tofrom = {0};
+ stralloc text = {0};
+@@ -64,7 +54,7 @@
+ if (!(user = env_get("USER"))) _exit(0);
+ if (!(sender = env_get("SENDER"))) _exit(0);
+ if (!(userext = env_get("LOCAL"))) _exit(0);
+- if (str_len(user) > sizeof(ut.ut_name)) _exit(0);
++ if (str_len(user) > sizeof(ut->ut_user)) _exit(0);
+
+ if (!stralloc_copys(&tofrom,"*** TO <")) _exit(0);
+ if (!stralloc_cats(&tofrom,userext)) _exit(0);
+@@ -89,15 +79,11 @@
+ if (!stralloc_cat(&woof,&text)) _exit(0);
+ if (!stralloc_cats(&woof,"\015\n")) _exit(0);
+
+- fdutmp = open_read(UTMP_FILE);
+- if (fdutmp == -1) _exit(0);
+- substdio_fdbuf(&ssutmp,read,fdutmp,bufutmp,sizeof(bufutmp));
+-
+- while (substdio_get(&ssutmp,&ut,sizeof(ut)) == sizeof(ut))
+- if (!str_diffn(ut.ut_name,user,sizeof(ut.ut_name)))
++ while ((ut = getutxent()) != NULL)
++ if (ut->ut_type == USER_PROCESS && !str_diffn(ut->ut_user,user,sizeof(ut->ut_user)))
+ {
+- byte_copy(line,sizeof(ut.ut_line),ut.ut_line);
+- line[sizeof(ut.ut_line)] = 0;
++ byte_copy(line,sizeof(ut->ut_line),ut->ut_line);
++ line[sizeof(ut->ut_line)] = 0;
+ if (line[0] == '/') continue;
+ if (!line[0]) continue;
+ if (line[str_chr(line,'.')]) continue;
diff --git a/mail-mta/netqmail/files/conf-common b/mail-mta/netqmail/files/conf-common
index 613193c..008fe63 100644
--- a/mail-mta/netqmail/files/conf-common
+++ b/mail-mta/netqmail/files/conf-common
@@ -1,6 +1,6 @@
#!/bin/bash
# Common Configuration file for all qmail daemons
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-common,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-common,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Qmail User IDS to run daemons as
QMAILDUID=$(id -u qmaild)
@@ -17,7 +17,7 @@ TCPSERVER_PORT=${SERVICE}
# you do not need to specify -x, -c, -u or -g in this variable as those are
# added later
-TCPSERVER_OPTS="-p -v"
+TCPSERVER_OPTS="-p -v -R"
# This tells tcpserver where to file the rules cdb file
[[ -d /etc/tcprules.d/ ]] && \
@@ -25,9 +25,10 @@ TCPSERVER_OPTS="-p -v"
[[ ! -f "${TCPSERVER_RULESCDB}" ]] && \
TCPSERVER_RULESCDB=/etc/tcp.${SERVICE}.cdb
-# we limit data and stack segments to 8mbytes, you may need to raise this if
-# you are using a filter in QMAILQUEUE
-SOFTLIMIT_OPTS="-m 16000000"
+# we limit data and stack segments to 32mbytes, you may need to raise this if
+# you are using a filter in QMAILQUEUE.
+# Per bug #403893 amd64 needs a higher limit.
+SOFTLIMIT_OPTS="-m 32000000"
# We don't have anything to set QMAILQUEUE to at the moment, so we leave it
# alone. Generally it is best to add this in your appropriate (usually SMTP)
diff --git a/mail-mta/netqmail/files/conf-qmqpd b/mail-mta/netqmail/files/conf-qmqpd
index b362241..2b337d9 100644
--- a/mail-mta/netqmail/files/conf-qmqpd
+++ b/mail-mta/netqmail/files/conf-qmqpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-qmqpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmqpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmqpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Stuff to run before tcpserver
#QMAIL_TCPSERVER_PRE=""
@@ -8,8 +8,5 @@
# Stuff to after qmail-qmqpd
#QMAIL_QMQP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# I don't trust /etc/services to have obscure ports
TCPSERVER_PORT=628
diff --git a/mail-mta/netqmail/files/conf-qmtpd b/mail-mta/netqmail/files/conf-qmtpd
index 7116efc..6d6df72 100644
--- a/mail-mta/netqmail/files/conf-qmtpd
+++ b/mail-mta/netqmail/files/conf-qmtpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-qmtpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmtpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmtpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# For more information on making your servers talk QMTP
# see http://cr.yp.to/im/mxps.html
@@ -11,8 +11,5 @@
# Stuff to after qmail-qmtpd
#QMAIL_QMTP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# I don't trust /etc/services to have obscure ports
TCPSERVER_PORT=209
diff --git a/mail-mta/netqmail/files/conf-smtpd b/mail-mta/netqmail/files/conf-smtpd
index cfbdad4..d7cc2c3 100644
--- a/mail-mta/netqmail/files/conf-smtpd
+++ b/mail-mta/netqmail/files/conf-smtpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-smtpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-smtpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-smtpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Stuff to run before tcpserver
#QMAIL_TCPSERVER_PRE=""
@@ -8,9 +8,6 @@
# Stuff to after qmail-smtpd
#QMAIL_SMTP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# fixcrio inserts missing CRs at the ends of lines. See:
# http://cr.yp.to/ucspi-tcp/fixcrio.html
# http://cr.yp.to/docs/smtplf.html
diff --git a/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch b/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch
new file mode 100644
index 0000000..1eb334c
--- /dev/null
+++ b/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch
@@ -0,0 +1,13 @@
+diff -Nuar genqmail-20080406.orig/spp/Makefile genqmail-20080406/spp/Makefile
+--- genqmail-20080406.orig/spp/Makefile 2008-04-06 15:44:14.000000000 +0000
++++ genqmail-20080406/spp/Makefile 2013-05-27 00:37:58.687763457 +0000
+@@ -14,7 +14,7 @@
+ rm -f $(TARGETS)
+
+ $(RESOLV_OBJS):
+- $(CC) $(CFLAGS) -o $@ $@.c -lresolv
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $@.c -lresolv
+
+ $(SIMPLE_OBJS):
+- $(CC) $(CFLAGS) -o $@ $@.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $@.c
diff --git a/mail-mta/netqmail/files/servercert.cnf b/mail-mta/netqmail/files/servercert.cnf
index 735445e..aa48938 100644
--- a/mail-mta/netqmail/files/servercert.cnf
+++ b/mail-mta/netqmail/files/servercert.cnf
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/servercert.cnf,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/servercert.cnf,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# This is the openssl config file to generate keys for qmail
[ req ]
@@ -6,7 +6,7 @@
# this should be a power of 2!
default_bits = 1024
# leave the rest of these alone!
-encrypt_key = yes
+encrypt_key = no
distinguished_name = req_dn
x509_extensions = cert_type
prompt = no