summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/openvdb-7.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/openvdb/openvdb-7.0.0.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-7.0.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/media-gfx/openvdb/openvdb-7.0.0.ebuild b/media-gfx/openvdb/openvdb-7.0.0.ebuild
deleted file mode 100644
index c7f8dd8..0000000
--- a/media-gfx/openvdb/openvdb-7.0.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-utils flag-o-matic python-single-r1
-
-DESCRIPTION="Libs for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc python test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=dev-libs/boost-1.62:=
- >=dev-libs/c-blosc-1.5.0
- dev-libs/jemalloc
- dev-libs/log4cplus
- media-libs/glfw:=
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-libs/boost-1.62:=[python,${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')
- )"
-
-DEPEND="${RDEPEND}
- dev-cpp/tbb
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_NO_SYSTEM_FROM_IMPORTED=true
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_RPATH=OFF
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
-
- cmake-utils_src_configure
-}