summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cgal/Manifest5
-rw-r--r--sci-mathematics/cgal/cgal-5.0.2.ebuild80
-rw-r--r--sci-mathematics/cgal/files/cgal-4.11.1-fix-buildsystem.patch15
-rw-r--r--sci-mathematics/cgal/metadata.xml28
4 files changed, 128 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
new file mode 100644
index 0000000..2481e38
--- /dev/null
+++ b/sci-mathematics/cgal/Manifest
@@ -0,0 +1,5 @@
+AUX cgal-4.11.1-fix-buildsystem.patch 840 BLAKE2B e1179b2721e52b2edf305e2cb434a914f0b46b6aa694fd1766a8622b65ed8e8209a06bc134bfab97f07b789af45f74605fc7ed2b6c45ed5f5574a0a801c479dd SHA512 5e6315dfa64c58ea88d473b3513ec0817e6d212c325dd70b523d2dca2817fed2cdb0791686b7353c410e42ff8b1ee228a045bd6f002b591672066b33ce6f09ad
+DIST CGAL-5.0.2-doc_html.tar.xz 47641328 BLAKE2B dcd78cca3aed5ef81b41f0a315e0132c011f81c84d79390ebaeaf73eb7a9ec8d440da980e44d9e2951cb63374d03682e8d7782fcb1c20ee6e1b6d99a98d51949 SHA512 4409a5a6a9348b393f900fb75cafb6caa143d2c6d68027f7380a2d4a9520014a8852549f7b00cc34aabc85c808c93ae73d1562b790f9957c919bad8b2675e618
+DIST CGAL-5.0.2.tar.xz 22147464 BLAKE2B 9875d34ca39ea65c3d44a2fcd50fba6d5964d142d9116ea8125acc0adec6d56eadf9a8f2457720fc1989ef2985e1ea29348a078e60afbf921fca5d09f9bfbccc SHA512 bec4877b244a20eaf331c737000470309b937510b117ad221b0362571a2b2edc096f1cc17dffbef2192126f57ab0150388ab474051e76f6bab53fb8361eab7e2
+EBUILD cgal-5.0.2.ebuild 1834 BLAKE2B 336ba9d41d3074b72755c42c520bae9be793cc4f54f3809046f17c77b84729b82b5bc50002e0b7013d30d74078bf4b07b3f6358b7ef85fd13db2790e929f7dd3 SHA512 bfbad9385266c0b0cb65c3efb9215c96c497e39a77284b0597c3ef82b2950a60da4bdc12c183e62d074fc96260ab76b8eee23de348e1ae26586d6854ebea8423
+MISC metadata.xml 1320 BLAKE2B 783149a7fc48a50a58319ff81790908eb6294bf1fae99fcf8cffd6249ef1c60c1a87f3d818352f70b36790d2fd9ffb0daa9b16d918625a27f82b843579228fd1 SHA512 ee385a11e84af08f5c8146da067d27beceea4f15b2ede403ed799dc7766a4f749904356f22175eceb121555d6a40f3994381f6a1f8d2a90178962b65cf2a40d0
diff --git a/sci-mathematics/cgal/cgal-5.0.2.ebuild b/sci-mathematics/cgal/cgal-5.0.2.ebuild
new file mode 100644
index 0000000..b4978c6
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-5.0.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+MY_P=CGAL-${PV}
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="https://www.cgal.org/"
+SRC_URI="
+ https://github.com/CGAL/cgal/releases/download/releases%2F${MY_P}/${MY_P}.tar.xz
+ doc? ( https://github.com/CGAL/cgal/releases/download/releases%2F${MY_P}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0/13"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi ntl qt5"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/boost:=[threads]
+ dev-libs/mpfr:0=
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ virtual/glu:=
+ virtual/opengl:=
+ gmp? ( dev-libs/gmp:=[cxx] )
+ mpfi? ( sci-libs/mpfi )
+ ntl? ( dev-libs/ntl )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.11.1-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # modules provided by dev-util/cmake and dev-cpp/eigen
+ rm cmake/modules/FindEigen3.cmake || die
+ sed -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR="$(get_libdir)"
+ -DCGAL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/CGAL"
+ -DWITH_LEDA=OFF
+ -DWITH_Eigen3=ON
+ -DWITH_ZLIB=ON
+ -DWITH_GMP="$(usex gmp)"
+ -DWITH_GMPXX="$(usex gmp)"
+ -DWITH_MPFI="$(usex mpfi)"
+ -DWITH_NTL="$(usex ntl)"
+ -DWITH_CGAL_Qt5="$(usex qt5)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ dodoc -r examples demo
+ docompress -x /usr/share/doc/${PF}/{examples,demo}
+ fi
+}
diff --git a/sci-mathematics/cgal/files/cgal-4.11.1-fix-buildsystem.patch b/sci-mathematics/cgal/files/cgal-4.11.1-fix-buildsystem.patch
new file mode 100644
index 0000000..e6c9cd9
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-4.11.1-fix-buildsystem.patch
@@ -0,0 +1,15 @@
+diff -urEbwB CGAL-4.11.1/cmake/modules/CGAL_SetupFlags.cmake CGAL-4.11.1.new/cmake/modules/CGAL_SetupFlags.cmake
+--- CGAL-4.11.1/cmake/modules/CGAL_SetupFlags.cmake 2018-02-24 21:00:36.000000000 +0100
++++ CGAL-4.11.1.new/cmake/modules/CGAL_SetupFlags.cmake 2018-03-05 12:13:47.233411449 +0100
+@@ -61,11 +61,6 @@
+ add_definitions(-DCGAL_TEST_SUITE)
+ endif()
+
+-if ( NOT "${CMAKE_BUILD_TYPE}" STREQUAL "Release" AND NOT "${CMAKE_BUILD_TYPE}" STREQUAL "Debug"
+- AND NOT "${CMAKE_BUILD_TYPE}" STREQUAL "RelWithDebInfo" AND NOT "${CMAKE_BUILD_TYPE}" STREQUAL "MinSizeRel" )
+- message( FATAL_ERROR "${CMAKE_BUILD_TYPE} is not a valid build type: only Release, Debug, RelWithDebInfo or MinSizeRel is allowed" )
+-endif()
+-
+ message( STATUS "Build type: ${CMAKE_BUILD_TYPE}" )
+
+ string( TOUPPER "${CMAKE_BUILD_TYPE}" CGAL_BUILD_TYPE_UPPER )
diff --git a/sci-mathematics/cgal/metadata.xml b/sci-mathematics/cgal/metadata.xml
new file mode 100644
index 0000000..ec85a1d
--- /dev/null
+++ b/sci-mathematics/cgal/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Computational Geometry Algorithms Library is a collaborative
+ open source library containing:
+ * the Kernel with geometric primitives such as points, vectors,
+ lines, predicates for testing things such as relative positions of
+ points, and operations such as intersections and distance calculation.
+ * the Basic Library which is a collection of standard data
+ structures and geometric algorithms, such as convex hull in 2D/3D,
+ (Delaunay) triangulation in 2D/3D, planar map, polyhedron, smallest
+ enclosing circle, and multidimensional query structures.
+ * the Support Library which offers interfaces to other packages,
+ e.g., for visualisation, and I/O, and other support facilities.
+ </longdescription>
+ <use>
+ <flag name="mpfi">Enable support for multiple recision interval arithmetic via <pkg>sci-libs/mpfi</pkg></flag>
+ <flag name="ntl">Enable support for <pkg>dev-libs/ntl</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">CGAL/cgal</remote-id>
+ </upstream>
+</pkgmetadata>