summaryrefslogtreecommitdiff
path: root/x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild')
-rw-r--r--x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild b/x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild
new file mode 100644
index 0000000..47869e2
--- /dev/null
+++ b/x11-themes/notification-daemon-engine-nodoka/notification-daemon-engine-nodoka-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="notification-daemon theme developed by the Fedora Project"
+HOMEPAGE="https://fedorahosted.org/nodoka/"
+SRC_URI="https://fedorahosted.org/releases/n/o/nodoka/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/"${P}"-fromgit.patch
+}
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}