aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTommi Virtanen <tv@eagain.net>2007-11-15 21:11:59 +0200
committerTommi Virtanen <tv@eagain.net>2007-11-15 21:11:59 +0200
commit24e1196507148741c0b78ae813dbd9bc5a0ad149 (patch)
tree9fc42693e3ff608a882f44dbb8559235f2a89c0e /setup.py
parentCreate leading directories when creating missing repos in gitosis-serve. (diff)
downloadgitosis-dakkar-24e1196507148741c0b78ae813dbd9bc5a0ad149.tar.gz
gitosis-dakkar-24e1196507148741c0b78ae813dbd9bc5a0ad149.tar.bz2
gitosis-dakkar-24e1196507148741c0b78ae813dbd9bc5a0ad149.zip
Depend on a new enough setuptools to preserve data file access modes.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4e82d1d..30eb9a5 100755
--- a/setup.py
+++ b/setup.py
@@ -56,5 +56,12 @@ arbitrary commands.
# templates need to be a real directory, for git init
zip_safe=False,
+
+ install_requires=[
+ # setuptools 0.6a9 will have a non-executeable post-update
+ # hook, this will make gitosis-admin settings not update
+ # (fixed in 0.6c5, maybe earlier)
+ 'setuptools>=0.6c5',
+ ],
)