aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL105
1 files changed, 105 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..38c144a
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,105 @@
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.030.
+use strict;
+use warnings;
+
+use 5.036000;
+
+use ExtUtils::MakeMaker 7.30;
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "minimal mailing list manager",
+ "AUTHOR" => "Gianni Ceccarelli <dakkar\@thenautilus.net>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => "7.66"
+ },
+ "DISTNAME" => "Sietima",
+ "LICENSE" => "perl",
+ "MIN_PERL_VERSION" => "5.036000",
+ "NAME" => "Sietima",
+ "PREREQ_PM" => {
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.953",
+ "Email::Sender::Simple" => "2.600",
+ "Email::Stuffer" => "0.020",
+ "List::AllUtils" => "0.19",
+ "Mail::DMARC::PurePerl" => "1.20230215",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
+ "MooX::Traits" => "0.005",
+ "Type::Library" => "2.002001",
+ "Type::Params" => "2.002001",
+ "Type::Utils" => "2.002001",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.002001",
+ "Types::URI" => "0.007",
+ "feature" => "1.72",
+ "namespace::clean" => "0.27",
+ "strict" => "1.12",
+ "warnings" => "1.58"
+ },
+ "TEST_REQUIRES" => {
+ "Data::Printer" => "1.001000",
+ "Email::Sender::Transport::Test" => "2.600",
+ "Import::Into" => "1.002005",
+ "Net::DNS::Resolver::Mock" => "1.20230216",
+ "Path::Tiny" => "0.144",
+ "Test2::API" => "1.302192",
+ "Test2::V0" => "0.000145",
+ "URI" => "5.17",
+ "lib" => "0.65"
+ },
+ "VERSION" => "1.1.2",
+ "test" => {
+ "TESTS" => "t/*.t t/tests/*.t t/tests/sietima/*.t t/tests/sietima/multi-role/*.t t/tests/sietima/role/*.t t/tests/sietima/role/nospoof/*.t t/tests/sietima/role/subscriberonly/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "App::Spec" => "0.013",
+ "App::Spec::Run" => "0.013",
+ "Data::Printer" => "1.001000",
+ "Digest::SHA" => "6.04",
+ "Email::Address" => "1.913",
+ "Email::MIME" => "1.953",
+ "Email::Sender::Simple" => "2.600",
+ "Email::Sender::Transport::Test" => "2.600",
+ "Email::Stuffer" => "0.020",
+ "Import::Into" => "1.002005",
+ "List::AllUtils" => "0.19",
+ "Mail::DMARC::PurePerl" => "1.20230215",
+ "Moo" => "2.005005",
+ "Moo::Role" => "2.005005",
+ "MooX::Traits" => "0.005",
+ "Net::DNS::Resolver::Mock" => "1.20230216",
+ "Path::Tiny" => "0.144",
+ "Test2::API" => "1.302192",
+ "Test2::V0" => "0.000145",
+ "Type::Library" => "2.002001",
+ "Type::Params" => "2.002001",
+ "Type::Utils" => "2.002001",
+ "Types::Path::Tiny" => "0.006",
+ "Types::Standard" => "2.002001",
+ "Types::URI" => "0.007",
+ "URI" => "5.17",
+ "feature" => "1.72",
+ "lib" => "0.65",
+ "namespace::clean" => "0.27",
+ "strict" => "1.12",
+ "warnings" => "1.58"
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);