summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordakkar <dakkar@thenautilus.net>2023-10-12 09:48:37 +0100
committerdakkar <dakkar@thenautilus.net>2023-10-12 09:48:37 +0100
commitc874c8e9432a90749d57525cd6ca732f629436bb (patch)
treebc4fb2468a16f19043b3885e0e0249c0c47f78b1
downloadportage-patches-c874c8e9432a90749d57525cd6ca732f629436bb.tar.gz
portage-patches-c874c8e9432a90749d57525cd6ca732f629436bb.tar.bz2
portage-patches-c874c8e9432a90749d57525cd6ca732f629436bb.zip
from exelion
-rw-r--r--app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-python3.10.patch13
-rw-r--r--app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python.patch14
-rw-r--r--app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python3.10.patch122
-rw-r--r--app-i18n/ibus-1.5.27/ibus-1.5.27-emoji-fix.patch21
-rw-r--r--app-office/ledger-3.2.1/ledger-3.2.1-add-boost-1.76-compatibility.patch60
-rw-r--r--x11-terms/alacritty/meta-sends-esc.patch13
6 files changed, 243 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-python3.10.patch b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-python3.10.patch
new file mode 100644
index 0000000..eacc77a
--- /dev/null
+++ b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-python3.10.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/852152
+
+--- VirtualBox-6.1.34/configure
++++ VirtualBox-6.1.34/configure
+@@ -2027,7 +2027,7 @@
+ }
+ EOF
+ found=
+- SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m"
++ SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m python3.10 python3.10m"
+ for p in $PYTHONDIR; do
+ for d in $SUPPYTHONLIBS; do
+ for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
diff --git a/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python.patch b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python.patch
new file mode 100644
index 0000000..3a6da1f
--- /dev/null
+++ b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python.patch
@@ -0,0 +1,14 @@
+diff --git a/configure b/configure
+index fd2e296..695f6a7 100755
+--- a/configure
++++ b/configure
+@@ -1987,6 +1987,9 @@ check_python()
+ {
+ test_header "Python support"
+
++ # We force the right implementation in the ebuild instead
++ return
++
+ # On darwin this is a on/off decision only
+ if [ "$OS" = "darwin" ]; then
+ echo "enabled"
diff --git a/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python3.10.patch b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python3.10.patch
new file mode 100644
index 0000000..e06e869
--- /dev/null
+++ b/app-emulation/virtualbox-6.1.32-r2/virtualbox-6.1.34-r3-python3.10.patch
@@ -0,0 +1,122 @@
+https://github.com/archlinux/svntogit-community/blob/b103146beee8b7c70d04685033a8536aed2e5aea/trunk/002-python310.patch
+https://github.com/archlinux/svntogit-community/blob/b103146beee8b7c70d04685033a8536aed2e5aea/trunk/003-pyunicode.patch
+
+https://www.virtualbox.org/changeset/90537/vbox
+https://www.virtualbox.org/changeset/86623/vbox
+--- a/src/libs/xpcom18a4/python/src/module/_xpcom.cpp
++++ b/src/libs/xpcom18a4/python/src/module/_xpcom.cpp
+@@ -84,7 +84,11 @@
+ # define MANGLE_MODULE_INIT(a_Name) RT_CONCAT(a_Name, MODULE_NAME_SUFFIX)
+ # endif
+ # ifdef VBOX_PYXPCOM_VERSIONED
+-# if PY_VERSION_HEX >= 0x03090000 && PY_VERSION_HEX < 0x030a0000
++# if PY_VERSION_HEX >= 0x030a0000 && PY_VERSION_HEX < 0x030b0000
++# define MODULE_NAME MANGLE_MODULE_NAME("VBoxPython3_10")
++# define initVBoxPython MANGLE_MODULE_INIT(PyInit_VBoxPython3_10)
++
++# elif PY_VERSION_HEX >= 0x03090000 && PY_VERSION_HEX < 0x030a0000
+ # define MODULE_NAME MANGLE_MODULE_NAME("VBoxPython3_9")
+ # define initVBoxPython MANGLE_MODULE_INIT(PyInit_VBoxPython3_9)
+
+--- a/src/libs/xpcom18a4/python/Makefile.kmk
++++ b/src/libs/xpcom18a4/python/Makefile.kmk
+@@ -4,7 +4,7 @@
+ #
+
+ #
+-# Copyright (C) 2009-2017 Oracle Corporation
++# Copyright (C) 2009-2021 Oracle Corporation
+ #
+ # This file is part of VirtualBox Open Source Edition (OSE), as
+ # available from http://www.virtualbox.org. This file is free software;
+@@ -20,7 +20,7 @@
+
+ #
+ # List of supported Python versions, defining a number of
+-# VBOX_PYTHON[26|27|31|32|32M|33|33M|34|34M|35|35M|36|36M|37|37M|38|38M|39|39M|DEF]_[INC|LIB] variables
++# VBOX_PYTHON[26|27|31|32|32M|33|33M|34|34M|35|35M|36|36M|37|37M|38|38M|39|39M|310|310M|DEF]_[INC|LIB] variables
+ # which get picked up below.
+ #
+ ifeq ($(KBUILD_TARGET),darwin) # Relatively predictable, don't script.
+@@ -646,6 +646,52 @@
+ endif
+ endif
+
++ifdef VBOX_PYTHON310_INC
++#
++# Python 3.10 version
++#
++DLLS += VBoxPython3_10
++VBoxPython3_10_EXTENDS = VBoxPythonBase
++VBoxPython3_10_EXTENDS_BY = appending
++VBoxPython3_10_TEMPLATE = XPCOM
++VBoxPython3_10_INCS = $(VBOX_PYTHON310_INC)
++VBoxPython3_10_LIBS = $(VBOX_PYTHON310_LIB)
++
++ ifdef VBOX_WITH_32_ON_64_MAIN_API
++ ifdef VBOX_PYTHON310_LIB_X86
++DLLS += VBoxPython3_10_x86
++VBoxPython3_10_x86_EXTENDS = VBoxPythonBase_x86
++VBoxPython3_10_x86_EXTENDS_BY = appending
++VBoxPython3_10_x86_TEMPLATE = XPCOM
++VBoxPython3_10_x86_INCS = $(VBOX_PYTHON310_INC)
++VBoxPython3_10_x86_LIBS = $(VBOX_PYTHON310_LIB_X86)
++ endif
++ endif
++endif
++
++ifdef VBOX_PYTHON310M_INC
++#
++# Python 3.10 version with pymalloc
++#
++DLLS += VBoxPython3_10m
++VBoxPython3_10m_EXTENDS = VBoxPythonBase_m
++VBoxPython3_10m_EXTENDS_BY = appending
++VBoxPython3_10m_TEMPLATE = XPCOM
++VBoxPython3_10m_INCS = $(VBOX_PYTHON310M_INC)
++VBoxPython3_10m_LIBS = $(VBOX_PYTHON310M_LIB)
++
++ ifdef VBOX_WITH_32_ON_64_MAIN_API
++ ifdef VBOX_PYTHON310M_LIB_X86
++DLLS += VBoxPython3_10m_x86
++VBoxPython3_10m_x86_EXTENDS = VBoxPythonBase_x86_m
++VBoxPython3_10m_x86_EXTENDS_BY = appending
++VBoxPython3_10m_x86_TEMPLATE_ = XPCOM
++VBoxPython3_10m_x86_INCS = $(VBOX_PYTHON310M_INC)
++VBoxPython3_10m_x86_LIBS = $(VBOX_PYTHON310M_LIB_X86)
++ endif
++ endif
++endif
++
+ ifdef VBOX_PYTHONDEF_INC
+ #
+ # Python without versioning
+@@ -730,4 +776,3 @@
+
+
+ include $(FILE_KBUILD_SUB_FOOTER)
+-
+
+--- a/src/libs/xpcom18a4/python/src/PyXPCOM.h
++++ b/src/libs/xpcom18a4/python/src/PyXPCOM.h
+@@ -137,12 +137,14 @@
+ # define PyInt_Check(o) PyLong_Check(o)
+ # define PyInt_AsLong(o) PyLong_AsLong(o)
+ # define PyNumber_Int(o) PyNumber_Long(o)
+-# ifndef PyUnicode_AsUTF8
+-# define PyUnicode_AsUTF8(o) _PyUnicode_AsString(o)
++# if !defined(Py_LIMITED_API) && PY_VERSION_HEX <= 0x03030000 /* 3.3 added PyUnicode_AsUTF8AndSize */
++# ifndef PyUnicode_AsUTF8
++# define PyUnicode_AsUTF8(o) _PyUnicode_AsString(o)
++# endif
++# ifndef PyUnicode_AsUTF8AndSize
++# define PyUnicode_AsUTF8AndSize(o,s) _PyUnicode_AsStringAndSize(o,s)
++# endif
+ # endif
+-# ifndef PyUnicode_AsUTF8AndSize
+-# define PyUnicode_AsUTF8AndSize(o,s) _PyUnicode_AsStringAndSize(o,s)
+-# endif
+ typedef struct PyMethodChain
+ {
+ PyMethodDef *methods;
+
diff --git a/app-i18n/ibus-1.5.27/ibus-1.5.27-emoji-fix.patch b/app-i18n/ibus-1.5.27/ibus-1.5.27-emoji-fix.patch
new file mode 100644
index 0000000..0788b9c
--- /dev/null
+++ b/app-i18n/ibus-1.5.27/ibus-1.5.27-emoji-fix.patch
@@ -0,0 +1,21 @@
+diff --git i/src/ibusshare.c w/src/ibusshare.c
+index 0c0bda1..7ec90f4 100644
+--- i/src/ibusshare.c
++++ w/src/ibusshare.c
+@@ -307,12 +307,15 @@ ibus_init (void)
+ IBUS_TYPE_TEXT;
+ IBUS_TYPE_ATTRIBUTE;
+ IBUS_TYPE_ATTR_LIST;
+- IBUS_TYPE_LOOKUP_TABLE;
+ IBUS_TYPE_COMPONENT;
++ IBUS_TYPE_EMOJI_DATA;
+ IBUS_TYPE_ENGINE_DESC;
++ IBUS_TYPE_LOOKUP_TABLE;
+ IBUS_TYPE_OBSERVED_PATH;
+ IBUS_TYPE_REGISTRY;
+ IBUS_TYPE_X_EVENT;
++ IBUS_TYPE_UNICODE_BLOCK;
++ IBUS_TYPE_UNICODE_DATA;
+ }
+
+ static GMainLoop *main_loop = NULL;
diff --git a/app-office/ledger-3.2.1/ledger-3.2.1-add-boost-1.76-compatibility.patch b/app-office/ledger-3.2.1/ledger-3.2.1-add-boost-1.76-compatibility.patch
new file mode 100644
index 0000000..4293afe
--- /dev/null
+++ b/app-office/ledger-3.2.1/ledger-3.2.1-add-boost-1.76-compatibility.patch
@@ -0,0 +1,60 @@
+From c4d9834d23ded06a43a334c0f2632228a8a62ae3 Mon Sep 17 00:00:00 2001
+From: Carlo Cabrera <30379873+carlocab@users.noreply.github.com>
+Date: Mon, 19 Apr 2021 09:56:31 +0100
+Subject: [PATCH] ledger: revision bump (boost 1.76.0)
+
+This adds a patch for Boost 1.76 compatibility, taken from
+
+ https://github.com/ledger/ledger/issues/2030
+---
+diff --git a/src/expr.cc b/src/expr.cc
+index c8945d3..136fc97 100644
+--- a/src/expr.cc
++++ b/src/expr.cc
+@@ -34,6 +34,7 @@
+ #include "expr.h"
+ #include "parser.h"
+ #include "scope.h"
++#include <memory>
+
+ namespace ledger {
+
+@@ -278,7 +279,7 @@ value_t expr_value(expr_t::ptr_op_t op)
+ value_t source_command(call_scope_t& args)
+ {
+ std::istream * in = NULL;
+- scoped_ptr<ifstream> stream;
++ std::unique_ptr<ifstream> stream;
+ string pathname;
+
+ if (args.has(0)) {
+diff --git a/src/format.h b/src/format.h
+index 15431cf..c12f1c9 100644
+--- a/src/format.h
++++ b/src/format.h
+@@ -44,6 +44,7 @@
+
+ #include "expr.h"
+ #include "unistring.h"
++#include <memory>
+
+ namespace ledger {
+
+@@ -65,7 +66,7 @@ class format_t : public expr_base_t<string>, public noncopyable
+ std::size_t min_width;
+ std::size_t max_width;
+ variant<string, expr_t> data;
+- scoped_ptr<struct element_t> next;
++ std::unique_ptr<struct element_t> next;
+
+ element_t() throw()
+ : supports_flags<>(), type(STRING), min_width(0), max_width(0) {
+@@ -103,7 +104,7 @@ class format_t : public expr_base_t<string>, public noncopyable
+ void dump(std::ostream& out) const;
+ };
+
+- scoped_ptr<element_t> elements;
++ std::unique_ptr<element_t> elements;
+
+ public:
+ static enum elision_style_t {
diff --git a/x11-terms/alacritty/meta-sends-esc.patch b/x11-terms/alacritty/meta-sends-esc.patch
new file mode 100644
index 0000000..89af647
--- /dev/null
+++ b/x11-terms/alacritty/meta-sends-esc.patch
@@ -0,0 +1,13 @@
+diff --git i/alacritty/src/input.rs w/alacritty/src/input.rs
+index 5728665..e7fec7a 100644
+--- i/alacritty/src/input.rs
++++ w/alacritty/src/input.rs
+@@ -1010,7 +1010,7 @@ impl<T: EventListener, A: ActionContext<T>> Processor<T, A> {
+
+ if alt_send_esc
+ && *self.ctx.received_count() == 0
+- && self.ctx.modifiers().alt()
++ && (self.ctx.modifiers().alt() || self.ctx.modifiers().logo())
+ && utf8_len == 1
+ {
+ bytes.insert(0, b'\x1b');