aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-05-05 15:34:07 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-05-18 13:39:37 +1000
commit66c997886424a20e92ce30fcfda46cbb5c7352ab (patch)
treeac0bb74524108dd208376258f181e7e8d2d4f682 /configure.ac
parentBump to 2.9.99 (diff)
downloadxf86-input-evdev-66c997886424a20e92ce30fcfda46cbb5c7352ab.tar.gz
xf86-input-evdev-66c997886424a20e92ce30fcfda46cbb5c7352ab.tar.bz2
xf86-input-evdev-66c997886424a20e92ce30fcfda46cbb5c7352ab.zip
Add the default evdev config
This used to be part of the server but now that we have two drivers doing the same thing (libinput, evdev) shift the configuration defaults to the driver. This way you get what you install. https://bugs.freedesktop.org/show_bug.cgi?id=89023 Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0d480a..f6fd2e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,13 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
+AC_ARG_WITH(xorg-conf-dir,
+ AC_HELP_STRING([--with-xorg-conf-dir=DIR],
+ [Default xorg.conf.d directory [[default=$prefix/share/X11/xorg.conf.d/]]]),
+ [xorgconfdir="$withval"],
+ [xorgconfdir="$prefix/share/X11/xorg.conf.d"])
+AC_SUBST(xorgconfdir)
+
# X Server SDK location is required to install evdev header files
# This location is also relayed in the xorg-evdev.pc file
sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`