aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 545014d..e558aad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,21 +53,6 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
-# Enable building everything in the test/ directory. These are uinput-based
-# devices that resemble random hardware that may or may not look like a mouse,
-# keyboard, etc.
-AC_ARG_ENABLE(testdevices,
- AC_HELP_STRING([--enable-testdevices], [Build uinput-based test devices]),
- [BUILD_TEST="yes"],
- [BUILD_TEST="no"])
-AM_CONDITIONAL([BUILD_TEST], [test "x$BUILD_TEST" = "xyes"])
-
-if test "x$BUILD_TEST" = "xyes"; then
- AC_CHECK_FUNC([dlopen], [],
- AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
- AC_SUBST([DLOPEN_LIBS])
-fi
-
# Checks for extensions
XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
@@ -96,5 +81,4 @@ AC_OUTPUT([Makefile
src/Makefile
man/Makefile
include/Makefile
- test/Makefile
xorg-evdev.pc])