summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGianni Ceccarelli <dakkar@thenautilus.net>2009-09-17 17:29:49 +0000
committerGianni Ceccarelli <dakkar@thenautilus.net>2009-09-17 17:29:49 +0000
commit1fc7a3f7ecd0d3427f965187705c8612ae5ce0af (patch)
tree9e6af250a831391c7774850778a5cf51bdc35b3a
parentnew git version (diff)
downloadgentoo-overlay-1fc7a3f7ecd0d3427f965187705c8612ae5ce0af.tar.gz
gentoo-overlay-1fc7a3f7ecd0d3427f965187705c8612ae5ce0af.tar.bz2
gentoo-overlay-1fc7a3f7ecd0d3427f965187705c8612ae5ce0af.zip
new cgit version
-rw-r--r--www-apps/cgit/Manifest4
-rw-r--r--www-apps/cgit/cgit-0.8.3.ebuild110
-rw-r--r--www-apps/cgit/metadata.xml33
3 files changed, 147 insertions, 0 deletions
diff --git a/www-apps/cgit/Manifest b/www-apps/cgit/Manifest
index 0063672..680970e 100644
--- a/www-apps/cgit/Manifest
+++ b/www-apps/cgit/Manifest
@@ -1,5 +1,9 @@
AUX cgitrc 2066 RMD160 31d621fb653cf118d40cc3bfa9b159e80a1f3ee4 SHA1 7172623dd7844ae7fc0ef4fc8136b85a4bfc5f49 SHA256 c5fc42bb8514415eb93e4f6a07bf25622d7f3b4c7c9b19ce6523722b8b4b4b20
AUX postinstall-en.txt 132 RMD160 d48bd3054fb61a275a8c46bd747ba52af73ebb36 SHA1 d8de0743cf3e44038be3c0017e55b43b4da2e4ae SHA256 e7966f520dacb50c2e38642f223caf2b3afbca913b4c99346b7f0286eeae8e26
DIST cgit-0.8.2.1.tar.bz2 50598 RMD160 2e83250130aa1d4f087c853567c794b58a24368c SHA1 1c40de81530a3c0513bc963cc81f14685448f6f9 SHA256 4cf40f0b857850ae4fb2354eb19e4ac168f47bc593cde286af75e58c5fea617d
+DIST cgit-0.8.3.tar.bz2 54775 RMD160 383f3547c34f7e015437e4af049372a0dbd05c5f SHA1 3957956d71acf2f4a7024bd8ee5ea6f967550d2f SHA256 e4e671ed43dbe7e69e591cfa7d927ec979f6080d9714c1069725209e62a9430d
DIST git-1.6.3.3.tar.bz2 2061691 RMD160 802ab3a44c27084ed199c77d0f8710da7a5793ec SHA1 200b49304696357ccf7a4837307348d681b7e04d SHA256 f94bc0d1fc861a12c7fb821b27a4e6a80901e84432cdb7894cb7a437d4c939ad
+DIST git-1.6.4.4.tar.bz2 2174826 RMD160 8bad28bf8aedc6d5a9dcae39736c1ceeabbbe992 SHA1 da66a6323cc0842b19e3dbc5bb8ee5a59975037f SHA256 fc7e4d6c4172c62c93d5e974019f7193b03c8bc0a1c6f3a9fcc1d0928b808d7a
EBUILD cgit-0.8.2.1.ebuild 2140 RMD160 a0f57cb227ad649cb32de5437bc972d16769d5c5 SHA1 c4f06b432f92b3ceda13375cedd331c66d3f8bce SHA256 f100a86bbd319ba6924d9961ce2f3df380b622cd6b27dd8f90c1d5eb0c0c7a14
+EBUILD cgit-0.8.3.ebuild 2140 RMD160 a0f57cb227ad649cb32de5437bc972d16769d5c5 SHA1 c4f06b432f92b3ceda13375cedd331c66d3f8bce SHA256 f100a86bbd319ba6924d9961ce2f3df380b622cd6b27dd8f90c1d5eb0c0c7a14
+MISC metadata.xml 1319 RMD160 b4f00cbcf7cb4e8d188da93d2ae61f71a1b0caf0 SHA1 a800dd105ab1beded3b7e7ca3221a6263fc5891b SHA256 c92ee65184d98d4a8efe09a5e9b40b89af639b68734c4be43e54a4f188746f1b
diff --git a/www-apps/cgit/cgit-0.8.3.ebuild b/www-apps/cgit/cgit-0.8.3.ebuild
new file mode 100644
index 0000000..6291a8c
--- /dev/null
+++ b/www-apps/cgit/cgit-0.8.3.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp
+
+use dataonly || GIT_V="$(git --version | cut -d ' ' -f 3)"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://hjemli.net/git/cgit/about/"
+SRC_URI="!dataonly? ( mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2 )
+ http://hjemli.net/git/cgit/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="standalone dataonly"
+
+# This is remote installation, so we don't need any depends
+use standalone || need_httpd_cgi
+
+RDEPEND="!dataonly? ( dev-util/git )
+ sys-libs/zlib
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cgit-${PV}"
+
+pkg_setup() {
+ if use standalone; then
+ use dataonly && die "standalone and dataonly are conflicting USE-flags"
+ use vhosts && ewarn "vhosts flag is useless with standalone installation"
+
+ # We're into fast-cgi environment, so we need user to operate on
+ enewuser cgit
+ enewgroup cgit
+ else
+ webapp_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ if ! use dataonly; then
+ rmdir git
+
+ mv "${WORKDIR}/git-${GIT_V}" git
+ fi
+}
+
+src_compile() {
+ # Skip compilation if this is dataonly build
+ use dataonly && return 0
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ if ! use dataonly; then
+ mv cgit cgit.cgi
+
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+
+ local cache_dir=/var/cache/cgit
+
+ dodir "${cache_dir}"
+ keepdir "${cache_dir}"
+
+ use standalone && fowners cgit:cgit "${cache_dir}"
+
+ dodoc cgitrc.5.txt
+ fi
+
+ if use standalone; then
+ dobin cgit.cgi
+ else
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins cgit.css cgit.png
+
+ if ! use dataonly; then
+ exeinto "${MY_CGIBINDIR}"
+ doexe cgit.cgi
+
+ insinto "${MY_APPDIR}"/conf
+ doins "${FILESDIR}"/cgitrc
+ webapp_configfile "${MY_APPDIR}"/conf/cgitrc
+ fi
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+ fi
+}
+
+pkg_postinst() {
+ # We don't want to use webapp if this is standalone setup
+ use standalone || webapp_pkg_postinst
+}
+
+pkg_prerm() {
+ # Same idea
+ use standalone || webapp_pkg_prerm
+}
diff --git a/www-apps/cgit/metadata.xml b/www-apps/cgit/metadata.xml
new file mode 100644
index 0000000..258dffc
--- /dev/null
+++ b/www-apps/cgit/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription lang="en">
+ From http://hjemli.net/git/cgit/about/:
+ cgit is
+ * a cgi application implemented in C: it's basically (yet) another git
+ command, used to generate html.
+ * not forking: all git operations are performed by linking with libgit.a.
+ * using a built-in cache: the generated html is stored on disk for the
+ benefit of later requests.
+ * fond of virtual urls - using PATH_INFO or modules like mod_rewrite makes
+ cgit generate urls with few or no querystring parameters, e.g.
+ http://hjemli.net/git/cgit/log/Makefile vs.
+ http://hjemli.net/git?r=cgit&amp;p=log&amp;path=Makefile.
+ * not too visual, but sometimes a bit of graphics can be justified.
+ * open source - it is licensed under GPL v2.
+ * maintained by Lars Hjemli, who is happy to receive patches, suggestions
+ and bug reports.
+ </longdescription>
+ <use>
+ <flag name="standalone">
+ Install only binary. Usefull for remote fastcgi setups
+ Conflicts with 'dataonly'
+ </flag>
+ <flag name="dataonly">
+ Do not install binary or any configs. Usefull for setups when real
+ binary located on other host. Conflicts with 'standalone'
+ </flag>
+ </use>
+</pkgmetadata>
+